Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can not log in to my ubuntu 12.4, not even as a guest. Every time i try it push me back to log in screen. And it says something like "suitable mode for kernel not found" I just instal ubuntu few weeks ago and was so happy with it until now. Can someone please help me.

I Solve the problem!!!!

I log in to bash, (Ctrl+Alt+F1)

sudo apt-get update

sudo apt-get install --reinstall ubuntu-desktop

and it worked for me ;)

share|improve this question
Have you made any modifications on your installation just before the issue appears? For example, installing drivers, updates...etc – Ahmadgeo Mar 25 '13 at 1:05
I dont remember I was doing any modifications, maybe I did something by accident Im new to all this – Hrvach Mar 25 '13 at 1:57
If you solved the problem, please post it as an answer yourself. – user98085 Mar 28 '13 at 0:35

Try the following.

When you reach the Login Screen , press CTRL+ALT+F1 to redirect to Console Mode. There login with your username & password and issue the following commands one by one

sudo service lightdm stop

rm ~/.Xauthority

sudo service lightdm start

retry to login now.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.