Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I don't know if this has happened to anyone else before, but I've googled everything I could about it and got nowhere. So, I'm posting here.

Um, as long as I've used Ubuntu, I'm still pretty basic about it. So, my computer died while I was away from home (yes, I leave my laptop at home), and when I came back, plugged in charger, and booted up, my homescreen suddenly has a drive icon for something labeled 2.1 GB Volume. I realise this is probaly a storage device, but I haven't plugged in anything aside from a mouse and a keyboard (piano) to it.

Whenever I attempt to mount it, I get an error full of coding gibberish.

 Error mounting /dev/sda5 at /media/**/aa56b0de-b6ca-364a-a7b1-ee9b53b18dfa: Command-line `mount -t "hfsplus" -o "uhelper=udisks2,nodev,nosuid" "/dev/sda5" "/media/**/aa56b0de-b6ca-364a-a7b1-ee9b53b18dfa"' exited with non-zero exit status >32: mount: wrong fs type, bad option, bad superblock on /dev/sda5,
      missing codepage or helper program, or other error
     In some cases useful info is found in syslog - try
    dmesg | tail  or so

Please help you guys, and sorry if this is a stupid question. I'm really good with Windows coding, but Mac and Linux coding is like German to me.

Also, this is not a life threatening problem, as far as I know. Just annoying, as I get popups about it occasionally. So, immediate answers are not needed (though appreciated).

EDIT: FSTAB-

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=4e8828f5-8b85-47c1-9391-f423aad2300f /               ext4    errors=remount-ro 0       >1
# swap was on /dev/sda5 during installation
#UUID=90c3a138-d633-4b2b-aa93-5eebe06f830d none            swap    sw              0       >0
/dev/mapper/cryptswap1 none swap sw 0 0

And Whatever that other thing was-

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0004b245

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   484343807   242170880   83  Linux
/dev/sda2       484345854   488396799     2025473    5  Extended
/dev/sda5       484345856   488396799     2025472   82  Linux swap / Solaris
share|improve this question
    
Can you add the outputs of sudo fdisk -l and cat /etc/fstab to the question. –  mikewhatever Mar 25 '13 at 0:13
    
So /dev/sda5 is the encrypted swap partition, and, for some reason, you've tried mounting it as hfsplus, which is Apple's file system. Here is a similar question, that's also been successfully resolved. –  mikewhatever Mar 25 '13 at 1:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.