Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been reading a book on Gimp. The book recommended that I visit the LinuxWacom Project for the drivers of a Wacom tablet I own.

After extracting the tarball, I have to configure and make install. But this part is where ./configure got interesting.

configure: error: Package requirements (xorg-server >= 1.7.0 xproto xext kbproto inputproto randrproto) were not met:

No package 'xorg-server' found
No package 'xproto' found
No package 'xext' found
No package 'kbproto' found
No package 'inputproto' found
No package 'randrproto' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XORG_CFLAGS
and XORG_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
john@kotux:~/xf86-input-wacom-0.20.0$ 

Not to mention my laptop on 12.10 has Xorg version 1.13.0. Not right.

I thought it was as simple as installing the missing dependencies via apt-get, but they didn't work.

john@kotux:~/xf86-input-wacom-0.20.0$ sudo apt-get install xorg-server xproto xext 
kbproto inputproto randrproto
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package xorg-server
E: Unable to locate package xproto
E: Unable to locate package xext
E: Unable to locate package kbproto
E: Unable to locate package inputproto
E: Unable to locate package randrproto

How can I install these missing packages? I wish the process does not require much manual installation.

share|improve this question
1  
Eh.. That looks pretty old. Have you tried configuring it via System Settings? –  Seth Mar 24 '13 at 21:58
add comment

2 Answers

up vote 2 down vote accepted

How old is the book?

I've been using GIMP on Ubuntu for 6+ years now. Even just a few years back, there were tons of configuration problems getting a Wacom tablet set up properly on Ubuntu (especially with dual-monitor setups).

Since 12.04 and 12.10, though, I have not had a single problem with Wacom tablets in Ubuntu. The automatic configuration works perfectly for me, even with my dual-monitor layout.

Try using the Wacom tablet settings in the regular System Settings application for Ubuntu. Unless you have a strange hardware configuration, there shouldn't be any need to install the driver yourself.

If you are having issues in GIMP specifically but not in other programs (try out Krita, MyPaint, etc.) then you can try editing the Input Device settings in GIMP to make sure that your tablet is not set to "disabled" in the program.

Either way, your tablet should work out of the box with the most recent versions of Ubuntu.

share|improve this answer
add comment

You need a lot of -dev packages to compile this. Try the following:

sudo apt-get install xserver-xorg-dev libxext-dev libxinerama-dev libxrandr-dev libxi-dev libudev-dev
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.