Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Ubuntu 12.04 32 bit. I have a Micromax Ninja A87 Android phone running GB 2.3.5. My problem is the phone does not get detected. When I try on a Windows 7 PC, it does get detected.

Here are all the steps I followed but still no lucks.

$ lsusb
Output: Bus 002 Device 006: ID 1c9e:9e08 OMEGA TECHNOLOGY

I created a file called 51-android.rules with this content:

SUBSYSTEM=="usb", ATTR{idVendor}=="1c9e", MODE="0666", GROUP="plugdev"
SUBSYSTEM=="usb", ATTR{idVendor}=="0bb4", MODE="0666", GROUP="plugdev"

Alternatively I tried this external link also.

Done chmod a+r on 51-android.rules. Restarted udev, also restarted my PC. Done kill-server & start-server. But still when I do adb devices it doesn't detect my phone.

Here are some more info:

  1. USB debugging is enabled in phone.
  2. Whenever I connect my phone to PC, it shows a popup in PC:

    usbmodem mass storage has been connected

share|improve this question

When checked the vendorId and productId in windows, it shows 1c9e:9e18. But in ubuntu it shows 1c9e:9e08. So tried to switch to same vendorId/productId i.e 1c9e:9e18. For this, create a rule in /etc/usb_modeswitch.d/1c9e:9e08 and put the below contents in the file:




Add below code to the file /lib/udev/rules.d/40-usb_modeswitch.rules

ATTR{idVendor}=="1c9e", ATTR{idProduct}=="9e08", RUN+="usb_modeswitch '%b/%k'"

once this is done, run :

sudo usb_modeswitch -v 0x1c9e -p 0x9e08 -S -R -W

Now adb will be able to recognise the phone.

For further reference you can go through the below link:

share|improve this answer

The problem is this that your device's primary flash space may not have drivers supported by Ubuntu. Windows is a more common and easy OS.. So your device manufacturer may provided windows drivers.... that's why it's working on 7

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.