Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A few iterations ago, I think this was Jaunty but could've been before, I would plug a 1/8" audio cable from the line-out of a Windows netbook to the line-in of my Ubuntu machine, so I would have all the sound from both machines without having to plug both into a mixer which I don't have. I didn't do this much, as I was pretty-much happy with Banshee at the time. But with Karmic, and still with Lucid, I can only get the output if I'm recording with Audacity. Which I'm not going to do from my web-development and systems programming workstation.

I can tell by plugging in headphones that my netbook has audio out working. I can see Sound Preferences that the Ubuntu machine is receiving them. I just want the old behavior back. Help?

share|improve this question

3 Answers 3

up vote 12 down vote accepted

If I understand correctly, you're trying to stream the microphone input to the audio output? The simplest I can think of is to use gst-launch for that. Open a terminal and type:

gst-launch pulsesrc ! pulsesink

The press CTRL+C to stop streaming. You may have to install the gstreamer tools to have this available:

sudo apt-get install gstreamer-tools

Note that as I don't have any suitable audio source, I didn't actually try that so it may not work. Any feedback on whether it does would be appreciated.

share|improve this answer
    
It works quite alright.. –  Source Lab Aug 22 '10 at 14:27
    
That it does. I got the answer on the weekend and have the problem on my work machine, so I didn't want to say OK until I tested it. And I'm testinb it right now. It does work. –  VarLogRant Aug 23 '10 at 12:19
    
Is this still the only fix? Nothing in the GUI? I'm running 13.04. –  Corey Apr 22 '13 at 17:29

Bruno Girin's answer worked for me as well, but manually launching a process is somewhat annoying as this should just be automatic. A better solution is to install gnome-alsamixer and unmute the line-in option, as described here:

No sound from line-in

share|improve this answer

If you want to use existing pulse-audio tools, use pacat (which stands for pulse-audio cat).

get your input device with

pactl list
[...]
Source #0
        State: SUSPENDED
        Name: alsa_output.pci-0000_00_1b.0.analog-stereo.monitor
        Description: Monitor of Built-in Audio Analog Stereo
        Driver: module-alsa-card.c
[...]

copy the 'name' part and use it with pacat :

pacat -r --device=alsa_input.pci-0000_00_1b.0.analog-stereo | pacat -p --latency-msec=1

where as device is the name you copied before.

This will cost a bit of CPU time (3,3% on my machine).

You can also pipe some audio converting software in between to filter, or use it over the network.

share|improve this answer
    
For list of possible devices, one can run pactl list short | egrep "alsa_(input|output)" | fgrep -v ".monitor". –  Mikko Rantalainen Oct 1 at 6:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.