Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Toshiba Satellite S855-S5378, and the wireless card doesn't work in Ubuntu 12.10 64-bit.

This is my kernel:

Linux 3.5.0-26-generic #42-Ubuntu SMP Fri Mar 8 23:18:20 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

This is my wireless card:

*-network
   descripción: Interfaz inalámbrica
   producto: Realtek Semiconductor Co., Ltd. [10EC:8723]
   fabricante: Realtek Semiconductor Co., Ltd. [10EC]
   id físico: 0
   información del bus: pci@0000:02:00.0
   nombre lógico: wlan0
   versión: 00
   serie: 20:68:9d:40:68:20
   anchura: 64 bits
   reloj: 33MHz
   capacidades: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuración: broadcast=yes driver=rtl8723e driverversion=3.5.0-26-generic firmware=N/A ip=192.168.1.104 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
   recursos: irq:17 ioport:2000(size=256) memoria:c8400000-c8403fff

I followed the steps in the following question:

and sucessfully installed the driver from the location. But sometimes the wireless doesn't recognize any network. It´s really rare. When I reboot the notebook, the wireless don't work. I try to use modprobe to load the module but without any success. But, when I shut down the PC, and then when it starts, the wireless works fine.

How do I solve this problem?

share|improve this question

1 Answer 1

You can find instructions to download and build the rtl8723 driver for Ubuntu 12.10 on various forums. I did that, and it worked. However, the driver seemed unstable. The wireless network would keep dropping out and restarting every few minutes.

So I decided to try Ubuntu 13.04 daily build version. Obviously it's not April yet, so Ubuntu 13.04 isn't officially released.

However, 13.04 does have support for Realtek rtl8723 driver, and it also has the Atheros alx driver if your wired ethernet card uses that driver.

Using the rtl8723 wireless driver supplied with Ubuntu 13.04 seems to work really good. It doesn't drop out all the time like with 12.10. I haven't tried the alx ethernet driver because the wireless works good enough that I don't need to.

The rtl8723 driver comes in the daily builds, so you don't need to download anything except the ISO. It can detect and use the wireless network even from a live USB stick "try Ubuntu" type of thingy.

If you want to try it, download the appropriate ISO file for your hardware from here: http://cdimage.ubuntu.com/daily-live/current/

I used unetbootin to make a USB stick bootable with the ISO file I downloaded.

Caveat: while running the live version off the stick, the unity interface didn't show up properly. Only the "Examples" folder and "Install Ubuntu" showed up, nothing else. Double clicking on these icons worked like you would expect. Ctrl-Alt-T brought up a terminal window. Once Ubuntu 13.04 was installed, unity works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.