Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi all as with a lot of people my new nvidia driver doesn't include a overscan bar so my tv's desktop is chopped off. After many searches and some trail and error I've been able to get my Tv to fit the desktop onto my screen using this command

nvidia-settings --assign 0/CurrentMetaMode="DFP-1: 1920x1080 { ViewPortIn=1920x1080, ViewPortOut=1820x1020+45+30 }"

But I can't seem to figure out a way to get that to happen on start-up. I've tried going to terminal and using

gedit ~/.nvidia-settings-rc and adding 0/CurrentMetaMode="DFP-1: 1920x1080 { ViewPortIn=1920x1080, ViewPortOut=1820x1020+45+30 }" 

to the end but that seems to not help. Is there maybe something else I can do or am I missing something? Any help is appreciated. At the moment I'm just copying and pasting the command after my pc boots into the terminal and it works but I feel there has to be a better way. Thanks again

share|improve this question

2 Answers 2

I don't know if you've found an answer already, but if not:

Put your settings in your /etc/X11/xorg.conf file, it will work.

For example :

Option         "metamodes" "DFP-0: nvidia-auto-select +0+0,DFP-1: 1280x720+1920+0 { ViewPortIn=1280x720, ViewPortOut=1210x670+35+25 }"
share|improve this answer
    
Sorry for the long time between posts. But at first I didn't have an xorg.conf fill and thought there was somthing wrong. Then I figured out how to get my nvidia Setting program to create the xorg.conf file and applied my settings. Now it's up and running. thanks again for the help. –  Tim Apr 13 '13 at 20:05

I just pasted the result someone else had into TERMINAL and it worked adequately as follows:

nvidia-settings -a CurrentMetaMode="DFP-0: 1680x1050+0+0, DFP-1: 1920x1080+1680+0 { ViewPortIn=1920x1080, ViewPortOut=1820x1022+50+29 }"

and hit enter. The result as explained in the below referenced article was 100 pixels less overscan all around.

Now I need to figure how and where to put this into the

(untested section below: It worked in terminal now i want it to become permanent as this is much too much to remember each login)

/etc/x11/xorg.conf 

to make the results persistent.

I found that clicking on the file folder under the "DASH" icon, and clicking on the filesystem menu and then clicking on the /etc and then clicking on the /x11 and clicking on the item that says xorg.conf it brings up in gedit a file. But this does not work because of permissions So one needs to in terminal type or copy

sudo gedit /etc/X11/xorg.conf

then add to the bottom of the "screen" section Just before the end section. I prefaced it with 8 spaces to line it up with the rest of the section.

nvidia-settings -a CurrentMetaMode="DFP-0: 1680x1050+0+0, DFP-1: 1920x1080+1680+0 { ViewPortIn=1920x1080, ViewPortOut=1820x1022+50+29 }"

Then save over the top of the original. (you did save The ORIGINAL AS as xorg.conf.old first didn't you? if it existed.)

REFERENCE ( url below ) explains how to derive your own results for whatever number of pixles you need. http://b.wardje.eu/2012/08/nvidia-linux-overscan.html

I am sure that someone with more experience can do a better job with this. But as long as this is in a vacuum it stands.

Thanks to all who put in the pieces.

--GND

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.