Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have had an Acer Revo box as a media centre for a while. I recently installed Ubuntu Server (10.10) on it and polished it up with nodm (one of the most simple ways to launch an X session) and installed boxee. It's been working fine for over a month.

It's just running ALSA. I've had problems with PulseAudio/Boxee/HDMI before so I wanted to keep it simple. And that worked. It pushed both PCM and digital (AAC and various Dolby codecs) over HDMI perfectly.

But I restarted it the other day after mucking around with some nfs configuration and now there isn't any sound.

The hardware is an ION chipset. Nvidia 9400M graphics with Nvidia MCP79/7A audio.

One thing I have noticed is there doesn't appear to be any sign of a IEC958 device. A traditional fix in the past for fresh installs has been to load alsamixer, find the IEC device and toggle its mute but I can't. I'm certain this used to represent the HDMI output. It just doesn't seem to exist any more unless I run sudo alsa-utils restart while boxee is running, when I see it in an error message:

* Shutting down ALSA...  [ OK ] 
* Setting up ALSA...
* warning: 'alsactl restore' failed with error message 'alsactl: set_control:1388: Cannot write control '2:0:0:IEC958 Playback Default:0' : Operation not permitted'...

When nodm (and thus boxee) aren't running, I don't see this error but alsamixer still doesn't show the IEC channel.

aplay -l gives:

card 0: NVidia [HDA NVidia], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

Its section in lshw reads:

         description: Audio device
         product: MCP79 High Definition Audio
         vendor: nVidia Corporation
         physical id: 8
         bus info: pci@0000:00:08.0
         version: b1
         width: 32 bits
         clock: 66MHz
         capabilities: pm bus_master cap_list
         configuration: driver=HDA Intel latency=0 maxlatency=5 mingnt=2
         resources: irq:22 memory:fae78000-fae7bfff

I was running on the stock PAE kernel but now it's running on I upgraded to see if that fixed things; it didn't.

I'm considering a reinstall but I hate doing that because a) there's a bit of custom configuration in getting X and Boxee to start on boot and b) I don't know what the problem is. If I reinstall this time, I'll end up doing that every time the sound breaks. I love Ubuntu but I don't want to install it once a month.

Is there any way to forcibly reset all alsa settings and restart from scratch (without doing a reinstall)? Any other tips?

If you need more information, just ask.

Debug information:

share|improve this question
How do you have audio setup in boxee its self? – Allan Feb 19 '11 at 23:02
@Allan Just as it has been: Digital out both analogue and passthrough set to hdmi. – Oli Feb 19 '11 at 23:21
just thought it had to be plughw:0,3 to go through alsa properly? – Allan Feb 19 '11 at 23:25
@Allan Tried that explicitly and no love. =( – Oli Feb 19 '11 at 23:54
up vote 2 down vote accepted

Fixed it. Turns out almost everything I observed was a complete red herring. Boxee was grabbing the sound device on boot and then wouldn't let its video player use it.

The fix is hacky but it works. It's a simple bait-and-switch. You write a script that edits the boxee config so the sound purposefully doesn't work, then start boxe (it tries to grab an imaginary card and fails) and then after a few seconds, the script puts the audio config back to what it should be, allowing videos to play sound.

Instead of running the boxee binary directly, you just call the script.


share|improve this answer
I was just about to suggest that Oli seriously. cough must make a note of that. – Allan Feb 20 '11 at 10:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.