Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an ubuntu 12.04 LTS guest in VBOX inside my native Windows 7. The graphics suddenly "stop drawing" or something, it stops updating the screen. I have tried adjusting the video memory (from 128mb to 64 mb and back), adjusting the RAM (it has 2048mb, before it was 1024mb) and tried running on the alternate chipset ICH9.

I noticed that inside Ubuntu, in the system settings->details, it says that the graphics driver is unknown, and the experience is standard. The guest additions are installed, but still. Is this normal?

Alternatively, what else can be wrong if this is not the issue?

UPDATE: I have now disabled the 3d acceleration. If someone knows how to solve this, please provide an answer, I will be super happy.

share|improve this question
    
try sudo apt-get install mesa-utils –  Web-E Mar 23 '13 at 18:31
    
After doing this driver is set to Chromium. Better, but it still doesn't draw the screen for instance on drag and drop of cards in Trello using Google Chrome. I just give up on 3d I think... –  Piddien Mar 23 '13 at 18:49
    
that was just to solve unknown graphics.. have u installed box guest editition? –  Web-E Mar 23 '13 at 18:52
    
yes the guest additions are installed. –  Piddien Mar 23 '13 at 18:53
    
See if 1) an update your guest Ubuntu (sudo apt-get update && sudo apt-get dist-upgrade or via Update Manager - you may have to reinstall the guest additions after that), and 2) an update of the drivers for your host (Windows) graphics card solves your issues. –  Takkat Mar 23 '13 at 19:28

1 Answer 1

I have a 12.04 guest working flawlessly both on Windows 7 and Ubuntu 13.04 hosts. We can compare both mine and yours and see what's different.

What is your version of VirtualBox? Is it the OSE or Oracle's Proprietary version?

Also, VirtualBox uses some portions of your real hardware. What's yours?

share|improve this answer
    
VBOX v 4.2.10. I read that I could use my 3d Graphics card directly but I have not done that as that is experimental. It has 2048 MB ram and the full 128MB of graphics memory. I had 2 processors, I try now to reduce it to 1 and turn off IO APIC. Seems to be very slow now, so I don't think this is the fix. –  Piddien Mar 23 '13 at 17:58
    
I have PAE/NX turned on –  Piddien Mar 23 '13 at 18:05
    
Runtime Attributes Screen Resolution 1600x774x32 Clipboard Mode Bidirectional Drag'n'Drop Mode Bidirectional VT-x/AMD-V Enabled Nested Paging Enabled Guest Additions 4.2.10 r84104 Guest OS Type Linux 2.6 (64 bit) Remote Desktop Server Port Not Available –  Piddien Mar 23 '13 at 18:28
    
Did you solve this? –  Hatredman May 2 '13 at 14:33
    
No I am running it without 3d. –  Piddien May 3 '13 at 13:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.