Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For a long time I've had problems with drivers for my card on Linux (Mint, Arch, Ubuntu).

When I use "Software Sources" to select the top NVIDIA driver, I reboot into a low resolution LightDM screen. I can login, but it's all low res and when I go to system settings -> display, the display is named "Laptop" and I can only select one resolution. nvidia-settings says I'm not using the nvidia driver, even after running sudo nvidia-xconfi and rebooting.

I read somewhere that I needed to install "nvidia-173" instead, so I uninstalled all other NVIDIA drivers and installed that.

When I rebooted, I get "The system is running in low-graphics mode". The reconfigure option and rebooting doesn't do anything. I read that reinstalling ubuntu-desktop should fix this, but it didn't for me. If I switch to tty1 and do startx, I see

Loading extension GLX
FATAL: module nvidia_173 not found.

Fatal server error:
no screens found

My card is a GT320.

edit: output from lspci | grep VGA:

01:00.0 VGA compatible controller: NVIDIA Corporation GT215 [GeForce GT 320] (rev a2)

Xorg.0.log:

[   404.480] 
X.Org X Server 1.13.0
Release Date: 2012-09-05
[   404.480] X Protocol Version 11, Revision 0
[   404.480] Build Operating System: Linux 3.2.0-32-generic x86_64 Ubuntu
[   404.480] Current Operating System: Linux Matthew-PC 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64
[   404.480] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=278a7dd6-0d6c-46e5-87e4-34a86130220d ro quiet splash vt.handoff=7
[   404.480] Build Date: 27 November 2012  07:44:35AM
[   404.480] xorg-server 2:1.13.0-0ubuntu6.1 (For technical support please see http://www.ubuntu.com/support) 
[   404.480] Current version of pixman: 0.26.0
[   404.480]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[   404.480] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   404.480] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Mar 23 15:29:20 2013
[   404.480] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   404.481] (==) No Layout section.  Using the first Screen section.
[   404.481] (==) No screen section available. Using defaults.
[   404.481] (**) |-->Screen "Default Screen Section" (0)
[   404.481] (**) |   |-->Monitor "<default monitor>"
[   404.481] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[   404.481] (==) Automatically adding devices
[   404.481] (==) Automatically enabling devices
[   404.481] (==) Automatically adding GPU devices
[   404.481] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   404.481]    Entry deleted from font path.
[   404.481] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[   404.481]    Entry deleted from font path.
[   404.481] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[   404.481]    Entry deleted from font path.
[   404.481] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[   404.481]    Entry deleted from font path.
[   404.481] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[   404.481]    Entry deleted from font path.
[   404.481] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[   404.481]    Entry deleted from font path.
[   404.481] (==) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/Type1,
    built-ins
[   404.481] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[   404.481] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[   404.481] (II) Loader magic: 0x7fdb87699c40
[   404.481] (II) Module ABI versions:
[   404.481]    X.Org ANSI C Emulation: 0.4
[   404.481]    X.Org Video Driver: 13.0
[   404.481]    X.Org XInput driver : 18.0
[   404.481]    X.Org Server Extension : 7.0
[   404.482] (--) PCI:*(0:1:0:0) 10de:0ca2:174b:2150 rev 162, Mem @ 0xfd000000/16777216, 0xd0000000/268435456, 0xce000000/33554432, I/O @ 0x0000dc00/128, BIOS @ 0x????????/524288
[   404.483] (II) Open ACPI successful (/var/run/acpid.socket)
[   404.483] Initializing built-in extension Generic Event Extension
[   404.483] Initializing built-in extension SHAPE
[   404.483] Initializing built-in extension MIT-SHM
[   404.483] Initializing built-in extension XInputExtension
[   404.483] Initializing built-in extension XTEST
[   404.483] Initializing built-in extension BIG-REQUESTS
[   404.483] Initializing built-in extension SYNC
[   404.483] Initializing built-in extension XKEYBOARD
[   404.483] Initializing built-in extension XC-MISC
[   404.483] Initializing built-in extension SECURITY
[   404.483] Initializing built-in extension XINERAMA
[   404.483] Initializing built-in extension XFIXES
[   404.483] Initializing built-in extension RENDER
[   404.483] Initializing built-in extension RANDR
[   404.483] Initializing built-in extension COMPOSITE
[   404.483] Initializing built-in extension DAMAGE
[   404.483] Initializing built-in extension MIT-SCREEN-SAVER
[   404.483] Initializing built-in extension DOUBLE-BUFFER
[   404.483] Initializing built-in extension RECORD
[   404.483] Initializing built-in extension DPMS
[   404.483] Initializing built-in extension X-Resource
[   404.483] Initializing built-in extension XVideo
[   404.483] Initializing built-in extension XVideo-MotionCompensation
[   404.483] Initializing built-in extension XFree86-VidModeExtension
[   404.483] Initializing built-in extension XFree86-DGA
[   404.483] Initializing built-in extension XFree86-DRI
[   404.483] Initializing built-in extension DRI2
[   404.483] (II) LoadModule: "glx"
[   404.483] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so
[   404.490] (II) Module glx: vendor="NVIDIA Corporation"
[   404.490]    compiled for 4.0.2, module version = 1.0.0
[   404.490]    Module class: X.Org Server Extension
[   404.490] (II) NVIDIA GLX Module  173.14.36  Wed Sep 12 01:06:34 PDT 2012
[   404.490] Loading extension GLX
[   404.490] (==) Matched nvidia as autoconfigured driver 0
[   404.490] (==) Matched nouveau as autoconfigured driver 1
[   404.490] (==) Matched nv as autoconfigured driver 2
[   404.490] (==) Matched vesa as autoconfigured driver 3
[   404.490] (==) Matched modesetting as autoconfigured driver 4
[   404.490] (==) Matched fbdev as autoconfigured driver 5
[   404.490] (==) Assigned the driver to the xf86ConfigLayout
[   404.490] (II) LoadModule: "nvidia"
[   404.490] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
[   404.491] (II) Module nvidia: vendor="NVIDIA Corporation"
[   404.491]    compiled for 4.0.2, module version = 1.0.0
[   404.491]    Module class: X.Org Video Driver
[   404.491] (II) LoadModule: "nouveau"
[   404.491] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[   404.491] (II) Module nouveau: vendor="X.Org Foundation"
[   404.491]    compiled for 1.13.0, module version = 1.0.2
[   404.491]    Module class: X.Org Video Driver
[   404.491]    ABI class: X.Org Video Driver, version 13.0
[   404.491] (II) LoadModule: "nv"
[   404.491] (WW) Warning, couldn't open module nv
[   404.492] (II) UnloadModule: "nv"
[   404.492] (II) Unloading nv
[   404.492] (EE) Failed to load module "nv" (module does not exist, 0)
[   404.492] (II) LoadModule: "vesa"
[   404.492] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[   404.492] (II) Module vesa: vendor="X.Org Foundation"
[   404.492]    compiled for 1.12.99.902, module version = 2.3.2
[   404.492]    Module class: X.Org Video Driver
[   404.492]    ABI class: X.Org Video Driver, version 13.0
[   404.492] (II) LoadModule: "modesetting"
[   404.492] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   404.492] (II) Module modesetting: vendor="X.Org Foundation"
[   404.492]    compiled for 1.13.0, module version = 0.5.0
[   404.492]    Module class: X.Org Video Driver
[   404.492]    ABI class: X.Org Video Driver, version 13.0
[   404.492] (II) LoadModule: "fbdev"
[   404.492] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[   404.492] (II) Module fbdev: vendor="X.Org Foundation"
[   404.492]    compiled for 1.12.99.902, module version = 0.4.3
[   404.492]    Module class: X.Org Video Driver
[   404.492]    ABI class: X.Org Video Driver, version 13.0
[   404.492] (==) Matched nvidia as autoconfigured driver 0
[   404.492] (==) Matched nouveau as autoconfigured driver 1
[   404.492] (==) Matched nv as autoconfigured driver 2
[   404.492] (==) Matched vesa as autoconfigured driver 3
[   404.492] (==) Matched modesetting as autoconfigured driver 4
[   404.492] (==) Matched fbdev as autoconfigured driver 5
[   404.492] (==) Assigned the driver to the xf86ConfigLayout
[   404.492] (II) LoadModule: "nvidia"
[   404.492] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
[   404.492] (II) Module nvidia: vendor="NVIDIA Corporation"
[   404.492]    compiled for 4.0.2, module version = 1.0.0
[   404.492]    Module class: X.Org Video Driver
[   404.492] (II) UnloadModule: "nvidia"
[   404.492] (II) Unloading nvidia
[   404.492] (II) Failed to load module "nvidia" (already loaded, 32731)
[   404.492] (II) LoadModule: "nouveau"
[   404.493] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[   404.493] (II) Module nouveau: vendor="X.Org Foundation"
[   404.493]    compiled for 1.13.0, module version = 1.0.2
[   404.493]    Module class: X.Org Video Driver
[   404.493]    ABI class: X.Org Video Driver, version 13.0
[   404.493] (II) UnloadModule: "nouveau"
[   404.493] (II) Unloading nouveau
[   404.493] (II) Failed to load module "nouveau" (already loaded, 32731)
[   404.493] (II) LoadModule: "nv"
[   404.493] (WW) Warning, couldn't open module nv
[   404.493] (II) UnloadModule: "nv"
[   404.493] (II) Unloading nv
[   404.493] (EE) Failed to load module "nv" (module does not exist, 0)
[   404.493] (II) LoadModule: "vesa"
[   404.493] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[   404.493] (II) Module vesa: vendor="X.Org Foundation"
[   404.493]    compiled for 1.12.99.902, module version = 2.3.2
[   404.493]    Module class: X.Org Video Driver
[   404.493]    ABI class: X.Org Video Driver, version 13.0
[   404.493] (II) UnloadModule: "vesa"
[   404.493] (II) Unloading vesa
[   404.493] (II) Failed to load module "vesa" (already loaded, 0)
[   404.493] (II) LoadModule: "modesetting"
[   404.493] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   404.493] (II) Module modesetting: vendor="X.Org Foundation"
[   404.493]    compiled for 1.13.0, module version = 0.5.0
[   404.493]    Module class: X.Org Video Driver
[   404.493]    ABI class: X.Org Video Driver, version 13.0
[   404.493] (II) UnloadModule: "modesetting"
[   404.493] (II) Unloading modesetting
[   404.493] (II) Failed to load module "modesetting" (already loaded, 0)
[   404.493] (II) LoadModule: "fbdev"
[   404.494] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[   404.494] (II) Module fbdev: vendor="X.Org Foundation"
[   404.494]    compiled for 1.12.99.902, module version = 0.4.3
[   404.494]    Module class: X.Org Video Driver
[   404.494]    ABI class: X.Org Video Driver, version 13.0
[   404.494] (II) UnloadModule: "fbdev"
[   404.494] (II) Unloading fbdev
[   404.494] (II) Failed to load module "fbdev" (already loaded, 0)
[   404.494] (II) NVIDIA dlloader X Driver  173.14.36  Wed Sep 12 00:56:02 PDT 2012
[   404.494] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   404.494] (II) NOUVEAU driver Date:   Wed Sep 12 13:42:43 2012 +0200
[   404.494] (II) NOUVEAU driver for NVIDIA chipset families :
[   404.494]    RIVA TNT        (NV04)
[   404.494]    RIVA TNT2       (NV05)
[   404.494]    GeForce 256     (NV10)
[   404.494]    GeForce 2       (NV11, NV15)
[   404.494]    GeForce 4MX     (NV17, NV18)
[   404.494]    GeForce 3       (NV20)
[   404.494]    GeForce 4Ti     (NV25, NV28)
[   404.494]    GeForce FX      (NV3x)
[   404.494]    GeForce 6       (NV4x)
[   404.494]    GeForce 7       (G7x)
[   404.494]    GeForce 8       (G8x)
[   404.494]    GeForce GTX 200 (NVA0)
[   404.494]    GeForce GTX 400 (NVC0)
[   404.494] (II) VESA: driver for VESA chipsets: vesa
[   404.494] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   404.494] (II) FBDEV: driver for framebuffer: fbdev
[   404.494] (++) using VT number 7

[   404.494] (II) Loading sub module "fb"
[   404.494] (II) LoadModule: "fb"
[   404.494] (II) Loading /usr/lib/xorg/modules/libfb.so
[   404.494] (II) Module fb: vendor="X.Org Foundation"
[   404.494]    compiled for 1.13.0, module version = 1.0.0
[   404.494]    ABI class: X.Org ANSI C Emulation, version 0.4
[   404.494] (II) Loading sub module "wfb"
[   404.494] (II) LoadModule: "wfb"
[   404.495] (II) Loading /usr/lib/xorg/modules/libwfb.so
[   404.495] (II) Module wfb: vendor="X.Org Foundation"
[   404.495]    compiled for 1.13.0, module version = 1.0.0
[   404.495]    ABI class: X.Org ANSI C Emulation, version 0.4
[   404.495] (II) Loading sub module "ramdac"
[   404.495] (II) LoadModule: "ramdac"
[   404.495] (II) Module "ramdac" already built-in
[   404.495] (WW) Falling back to old probe method for vesa
[   404.495] (WW) Falling back to old probe method for modesetting
[   404.495] (EE) open /dev/dri/card0: No such file or directory
[   404.495] (EE) open /dev/dri/card0: No such file or directory
[   404.495] (WW) Falling back to old probe method for fbdev
[   404.495] (II) Loading sub module "fbdevhw"
[   404.495] (II) LoadModule: "fbdevhw"
[   404.495] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[   404.495] (II) Module fbdevhw: vendor="X.Org Foundation"
[   404.495]    compiled for 1.13.0, module version = 0.0.2
[   404.495]    ABI class: X.Org Video Driver, version 13.0
[   404.495] (II) NVIDIA(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
[   404.495] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[   404.495] (==) NVIDIA(0): RGB weight 888
[   404.495] (==) NVIDIA(0): Default visual is TrueColor
[   404.495] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[   404.495] (**) NVIDIA(0): Enabling RENDER acceleration
[   404.495] (II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
[   404.495] (II) NVIDIA(0):     enabled.
[   404.497] (EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
[   404.497] (EE) NVIDIA(0):  *** Aborting ***
[   404.497] (II) UnloadModule: "nvidia"
[   404.497] (II) UnloadSubModule: "wfb"
[   404.497] (II) UnloadSubModule: "fb"
[   404.497] (EE) Screen(s) found, but none have a usable configuration.
[   404.497] 
Fatal server error:
[   404.497] no screens found
[   404.497] (EE) 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[   404.497] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   404.497] (EE) 
[   404.501] Server terminated with error (1). Closing log file.

edit: start of output from Xorg.0.log with nvidia-current (remember I get a low res display, my screen is called "Laptop" and nvidia-settings says I'm not using the nvidia driver):

[   192.911] 
X.Org X Server 1.13.0
Release Date: 2012-09-05
[   192.912] X Protocol Version 11, Revision 0
[   192.912] Build Operating System: Linux 3.2.0-32-generic x86_64 Ubuntu
[   192.912] Current Operating System: Linux Matthew-PC 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64
[   192.912] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=278a7dd6-0d6c-46e5-87e4-34a86130220d ro quiet splash
[   192.912] Build Date: 27 November 2012  07:44:35AM
[   192.912] xorg-server 2:1.13.0-0ubuntu6.1 (For technical support please see http://www.ubuntu.com/support) 
[   192.912] Current version of pixman: 0.26.0
[   192.912]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[   192.912] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   192.912] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Mar 23 16:00:03 2013
[   192.912] (==) Using config file: "/etc/X11/xorg.conf"
[   192.912] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   192.912] (==) ServerLayout "Layout0"
[   192.912] (**) |-->Screen "Screen0" (0)
[   192.912] (**) |   |-->Monitor "Monitor0"
[   192.913] (**) |   |-->Device "Device0"
[   192.913] (**) |-->Input Device "Keyboard0"
[   192.913] (**) |-->Input Device "Mouse0"
[   192.913] (==) Automatically adding devices
[   192.913] (==) Automatically enabling devices
[   192.913] (==) Automatically adding GPU devices
[   192.913] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   192.913]    Entry deleted from font path.
[   192.913] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[   192.913]    Entry deleted from font path.
[   192.913] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[   192.913]    Entry deleted from font path.
[   192.913] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[   192.913]    Entry deleted from font path.
[   192.913] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[   192.913]    Entry deleted from font path.
[   192.913] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
[   192.913]    Entry deleted from font path.
[   192.913] (==) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/Type1,
    built-ins
[   192.913] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[   192.913] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   192.913] (WW) Disabling Keyboard0
[   192.913] (WW) Disabling Mouse0
[   192.913] (II) Loader magic: 0x7f3790dbac40
[   192.913] (II) Module ABI versions:
[   192.913]    X.Org ANSI C Emulation: 0.4
[   192.913]    X.Org Video Driver: 13.0
[   192.913]    X.Org XInput driver : 18.0
[   192.913]    X.Org Server Extension : 7.0
[   192.914] (--) PCI:*(0:1:0:0) 10de:0ca2:174b:2150 rev 162, Mem @ 0xfd000000/16777216, 0xd0000000/268435456, 0xce000000/33554432, I/O @ 0x0000dc00/128, BIOS @ 0x????????/524288
[   192.914] (II) Open ACPI successful (/var/run/acpid.socket)
[   192.914] Initializing built-in extension Generic Event Extension
[   192.914] Initializing built-in extension SHAPE
[   192.914] Initializing built-in extension MIT-SHM
[   192.914] Initializing built-in extension XInputExtension
[   192.914] Initializing built-in extension XTEST
[   192.914] Initializing built-in extension BIG-REQUESTS
[   192.914] Initializing built-in extension SYNC
[   192.914] Initializing built-in extension XKEYBOARD
[   192.914] Initializing built-in extension XC-MISC
[   192.914] Initializing built-in extension SECURITY
[   192.914] Initializing built-in extension XINERAMA
[   192.914] Initializing built-in extension XFIXES
[   192.914] Initializing built-in extension RENDER
[   192.914] Initializing built-in extension RANDR
[   192.914] Initializing built-in extension COMPOSITE
[   192.914] Initializing built-in extension DAMAGE
[   192.914] Initializing built-in extension MIT-SCREEN-SAVER
[   192.915] Initializing built-in extension DOUBLE-BUFFER
[   192.915] Initializing built-in extension RECORD
[   192.915] Initializing built-in extension DPMS
[   192.915] Initializing built-in extension X-Resource
[   192.915] Initializing built-in extension XVideo
[   192.915] Initializing built-in extension XVideo-MotionCompensation
[   192.915] Initializing built-in extension XFree86-VidModeExtension
[   192.915] Initializing built-in extension XFree86-DGA
[   192.915] Initializing built-in extension XFree86-DRI
[   192.915] Initializing built-in extension DRI2
[   192.915] (II) LoadModule: "glx"
[   192.915] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so
[   192.928] (II) Module glx: vendor="NVIDIA Corporation"
[   192.928]    compiled for 4.0.2, module version = 1.0.0
[   192.928]    Module class: X.Org Server Extension
[   192.928] (II) NVIDIA GLX Module  304.43  Sun Aug 19 20:34:01 PDT 2012
[   192.928] Loading extension GLX
[   192.928] (II) LoadModule: "nvidia"
[   192.928] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
[   192.928] (II) Module nvidia: vendor="NVIDIA Corporation"
[   192.928]    compiled for 4.0.2, module version = 1.0.0
[   192.928]    Module class: X.Org Video Driver
[   192.930] (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
[   192.931] (EE) NVIDIA:     system's kernel log for additional error messages.
[   192.931] (II) UnloadModule: "nvidia"
[   192.931] (II) Unloading nvidia
[   192.931] (EE) Failed to load module "nvidia" (module-specific error, 0)
[   192.931] (==) Matched nvidia as autoconfigured driver 0
[   192.931] (==) Matched nouveau as autoconfigured driver 1
[   192.931] (==) Matched nv as autoconfigured driver 2
[   192.931] (==) Matched vesa as autoconfigured driver 3
[   192.931] (==) Matched modesetting as autoconfigured driver 4
[   192.931] (==) Matched fbdev as autoconfigured driver 5
[   192.931] (==) Assigned the driver to the xf86ConfigLayout
[   192.931] (II) LoadModule: "nvidia"
[   192.931] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
[   192.931] (II) Module nvidia: vendor="NVIDIA Corporation"
[   192.931]    compiled for 4.0.2, module version = 1.0.0
[   192.931]    Module class: X.Org Video Driver
[   192.933] (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
[   192.933] (EE) NVIDIA:     system's kernel log for additional error messages.
[   192.933] (II) UnloadModule: "nvidia"
[   192.933] (II) Unloading nvidia
[   192.933] (EE) Failed to load module "nvidia" (module-specific error, 0)
[   192.933] (II) LoadModule: "nouveau"
[   192.934] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[   192.934] (II) Module nouveau: vendor="X.Org Foundation"
[   192.934]    compiled for 1.13.0, module version = 1.0.2
[   192.934]    Module class: X.Org Video Driver
[   192.934]    ABI class: X.Org Video Driver, version 13.0
[   192.934] (II) LoadModule: "nv"
[   192.934] (WW) Warning, couldn't open module nv
[   192.934] (II) UnloadModule: "nv"
[   192.934] (II) Unloading nv
[   192.934] (EE) Failed to load module "nv" (module does not exist, 0)
[   192.934] (II) LoadModule: "vesa"
[   192.934] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[   192.934] (II) Module vesa: vendor="X.Org Foundation"
[   192.934]    compiled for 1.12.99.902, module version = 2.3.2
[   192.934]    Module class: X.Org Video Driver
[   192.934]    ABI class: X.Org Video Driver, version 13.0
[   192.934] (II) LoadModule: "modesetting"
[   192.935] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[   192.935] (II) Module modesetting: vendor="X.Org Foundation"
[   192.935]    compiled for 1.13.0, module version = 0.5.0
[   192.935]    Module class: X.Org Video Driver
[   192.935]    ABI class: X.Org Video Driver, version 13.0
[   192.935] (II) LoadModule: "fbdev"
[   192.935] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[   192.935] (II) Module fbdev: vendor="X.Org Foundation"
[   192.935]    compiled for 1.12.99.902, module version = 0.4.3
[   192.935]    Module class: X.Org Video Driver
[   192.935]    ABI class: X.Org Video Driver, version 13.0
[   192.935] (II) NOUVEAU driver Date:   Wed Sep 12 13:42:43 2012 +0200
[   192.935] (II) NOUVEAU driver for NVIDIA chipset families :
[   192.935]    RIVA TNT        (NV04)
[   192.935]    RIVA TNT2       (NV05)
[   192.935]    GeForce 256     (NV10)
[   192.935]    GeForce 2       (NV11, NV15)
[   192.935]    GeForce 4MX     (NV17, NV18)
[   192.935]    GeForce 3       (NV20)
[   192.935]    GeForce 4Ti     (NV25, NV28)
[   192.935]    GeForce FX      (NV3x)
[   192.935]    GeForce 6       (NV4x)
[   192.935]    GeForce 7       (G7x)
[   192.935]    GeForce 8       (G8x)
[   192.935]    GeForce GTX 200 (NVA0)
[   192.935]    GeForce GTX 400 (NVC0)
[   192.935] (II) VESA: driver for VESA chipsets: vesa
[   192.935] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   192.935] (II) FBDEV: driver for framebuffer: fbdev
[   192.935] (--) using VT number 8

[   193.022] (EE) [drm] failed to open device
[   193.022] (WW) Falling back to old probe method for modesetting
[   193.023] (EE) open /dev/dri/card0: No such file or directory
[   193.023] (WW) Falling back to old probe method for fbdev
[   193.023] (II) Loading sub module "fbdevhw"
[   193.023] (II) LoadModule: "fbdevhw"
[   193.023] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[   193.023] (II) Module fbdevhw: vendor="X.Org Foundation"
[   193.023]    compiled for 1.13.0, module version = 0.0.2
[   193.023]    ABI class: X.Org Video Driver, version 13.0
[   193.023] (EE) open /dev/fb0: No such file or directory
[   193.023] (II) Loading sub module "vbe"
[   193.023] (II) LoadModule: "vbe"
[   193.023] (II) Loading /usr/lib/xorg/modules/libvbe.so
[   193.023] (II) Module vbe: vendor="X.Org Foundation"
[   193.023]    compiled for 1.13.0, module version = 1.1.0
[   193.023]    ABI class: X.Org Video Driver, version 13.0
[   193.023] (II) Loading sub module "int10"
[   193.023] (II) LoadModule: "int10"
[   193.024] (II) Loading /usr/lib/xorg/modules/libint10.so
[   193.024] (II) Module int10: vendor="X.Org Foundation"
[   193.024]    compiled for 1.13.0, module version = 1.0.0
[   193.024]    ABI class: X.Org Video Driver, version 13.0
[   193.024] (II) VESA(0): initializing int10
[   193.024] (II) VESA(0): Bad V_BIOS checksum
[   193.024] (II) VESA(0): Primary V_BIOS segment is: 0xc000
[   193.064] (II) VESA(0): VESA BIOS detected
[   193.064] (II) VESA(0): VESA VBE Version 3.0
[   193.064] (II) VESA(0): VESA VBE Total Mem: 14336 kB
[   193.064] (II) VESA(0): VESA VBE OEM: NVIDIA
[   193.064] (II) VESA(0): VESA VBE OEM Software Rev: 112.21
[   193.064] (II) VESA(0): VESA VBE OEM Vendor: NVIDIA Corporation
[   193.064] (II) VESA(0): VESA VBE OEM Product: GT215 Board - 06840011
[   193.064] (II) VESA(0): VESA VBE OEM Product Rev: Chip Rev   
[   193.137] (**) VESA(0): Depth 24, (--) framebuffer bpp 32
[   193.137] (==) VESA(0): RGB weight 888
[   193.137] (==) VESA(0): Default visual is TrueColor
[   193.137] (==) VESA(0): Using gamma correction (1.0, 1.0, 1.0)
share|improve this question
    
See here. –  nerof61 Mar 23 '13 at 15:35
    
You should probably add the output of lspci to the question. I don't think the two things you've 'read somewhere' where correct. Nvidia-173 is too old for your card, and ubuntu-desktop is unrelated to graphics drivers. –  mikewhatever Mar 23 '13 at 15:41
    
That's where I got the suggestion to reinstall ubuntu-desktop from. I also tried to edit /etc/lightdm/lightdm.conf, but greeter-session is already set to unity-greeter. I had a look at the Xorg log. I will update my post. edit: @mikewhatever: is there somewhere I can find what driver I should use? I'll post the output of lspci now. –  Matthew Mar 23 '13 at 15:41
    
Don't know about the other distros, but on Ubuntu, I'd recommend the recommended driver - nvidia-current. –  mikewhatever Mar 23 '13 at 15:47
    
I tried that already, but as I said in my question, it's stuck in a low resolution and detects my main display as "Laptop". edit: also nvidia-settings says I'm not using the driver. –  Matthew Mar 23 '13 at 15:53
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.