Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install vmd on my ubuntu but " make install" is giving these errors. Can someone help? These are the errors. Thanks for the helps.

if [ ! -d "/usr/local/lib/vmd" ]; then \
        mkdir -p "/usr/local/lib/vmd" ; \
    fi ; \
    if [ ! -d "/usr/local/bin" ]; then \
        mkdir -p "/usr/local/bin" ; \
    fi ; \
    if [ ! -d "/usr/local/lib/vmd"/doc ]; then \
        mkdir -p "/usr/local/lib/vmd"/doc; \
    fi
cp ../Announcement  "/usr/local/lib/vmd"
cp: cannot create regular file `/usr/local/lib/vmd/Announcement': Permission denied
make: [install] Error 1 (ignored)
cp ../README        "/usr/local/lib/vmd"
cp: cannot create regular file `/usr/local/lib/vmd/README': Permission denied
make: [install] Error 1 (ignored)
cp ../LICENSE       "/usr/local/lib/vmd"
cp: cannot create regular file `/usr/local/lib/vmd/LICENSE': Permission denied
make: [install] Error 1 (ignored)
cp ../doc/ug.pdf        "/usr/local/lib/vmd"/doc
cp: cannot create regular file `/usr/local/lib/vmd/doc/ug.pdf': Permission denied
make: [install] Error 1 (ignored)
if [ -f /usr/local/lib/vmd/vmd_LINUXAMD64 ]; then \
           mv -f "/usr/local/lib/vmd/vmd_LINUXAMD64" "/usr/local/lib/vmd/OLD_vmd_LINUXAMD64" ; rm -f "/usr/local/lib/vmd/OLD_vmd_LINUXAMD64" ; fi
cp ../LINUXAMD64/vmd_LINUXAMD64 "/usr/local/lib/vmd"
cp: cannot overwrite directory `/usr/local/lib/vmd/vmd_LINUXAMD64' with non-directory
make: [install] Error 1 (ignored)
if [ -d "../lib/redistrib/lib_LINUXAMD64" ]; then \
        cd ../lib/redistrib/lib_LINUXAMD64; tar -cf - ./* | \
        (cd "/usr/local/lib/vmd" ; tar -xf -) \
    fi ;
tar: ./libcudart.so.4: Cannot open: Permission denied
tar: ./libexpat.so.0: Cannot open: Permission denied
tar: ./libsqlite3.so.0: Cannot open: Permission denied
tar: Exiting with failure status due to previous errors
make: *** [install] Error 2
share|improve this question

try this:

sudo make install

Generally make install needs root permissions to create new files in the filesystem.

share|improve this answer
    
<$>sudo make install</$> This Didnt Worked – user267036 Apr 9 '14 at 11:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.