Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use ubuntu 12.10 64 bit. Every time I turn my computer on, I have to manually connect to my bluetooth speakers and change audio output to bluetooth device.

I've found this question: Autoconnecting Bluetooth Devices.

Adding a following line to /etc/pulse/ doesn't help.

load-module module-switch-on-connect

I also installed stream2ip, but it says I don't have a bluetooth device.

Is there a way to accomplish this automatization?

share|improve this question
up vote 3 down vote accepted


There is a python tool bt-autoconnect designed to connect to an existing audio headset as soon as it becomes available. This is useful in case we do not want to load the pulseaudio module-switch-on-connect in our (see this question).

It will also connect a known device with the Bluetooth adapter (disable this if you want to connect manually), and it will be able to switch the audio sink to the Bluetooth sink without interrupting playback of an audio stream.

enter image description here

In case only one Bluetooth audio device is registered in Bluez settings we can choose "Auto" to autodetect this device. If we had paired more than one device we may need to specify the device by its MAC. If we do not specify the MAC bt-autoconnect will take the first device in the list which may not be the one we want.

If we choose to add bt-autoconnect to the Startup Applications it will start at login minimized to its Application Indicator only

In the Application Indicator menu we are able to switch between HSP (low quality telephony) profile with headset microphone enabled, or A2DP high quality audio profile where the microphone will not be available, provided this is supported by our headset.

enter image description here

share|improve this answer
Works like a charm. Thank you very much! – ezpn Mar 24 '13 at 12:05
Woorrrksssssssss – Capy Sep 28 '13 at 19:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.