Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use ubuntu version 12.10 64 bit. After I installed IBM SPSS Statistics v 21.0.0.0, I get the following java error, when trying to run the program:

Exception in thread "main"java.lang.UnsatisfiedLinkError: awt (An exception was pending after running JNI_OnLoad)
at java.lang.ClassLoader.loadLibraryWithPath(ClassLoader.java:1018)
at java.lang.ClassLoader.loadLibraryWithClassLoader(ClassLoader.java:982)
at java.lang.System.loadLibrary(System.java:469)
at sun.security.action.LoadLibraryAction.run(LoadLibraryAction.java:69)
at java.security.AccessController.doPrivileged(AccessController.java:202)
at java.awt.Toolkit.loadLibraries(Toolkit.java:1606)
at java.awt.Toolkit.<clinit>(Toolkit.java:1628)
at java.lang.J9VMInternals.initializeImpl(Native Method)
at java.lang.J9VMInternals.initialize(J9VMInternals.java:200)
at java.awt.AWTKeyStroke.<clinit>(AWTKeyStroke.java:81)
at java.lang.J9VMInternals.initializeImpl(Native Method)
at java.lang.J9VMInternals.initialize(J9VMInternals.java:200)
at java.lang.J9VMInternals.initialize(J9VMInternals.java:167)
at com.spss.charteditor.resources.LabelsBundle.<clinit>(Unknown Source)
at java.lang.J9VMInternals.initializeImpl(Native Method)
at java.lang.J9VMInternals.initialize(J9VMInternals.java:200)
at com.spss.charteditor.util.ResUtil.getBundle(Unknown Source)
at com.spss.charteditor.util.ResUtil.setLocale(Unknown Source)
at com.spss.java_client.core.common.ComponentState.setILangLocale(Unknown Source)
at com.spss.java_client.core.common.Driver.main(Unknown Source)
SPSS Client error:
Exception thrown by main.
java.lang.UnsatisfiedLinkError: awt (An exception was pending after running JNI_OnLoad)

My current java version is:

java version "1.7.0_15" OpenJDK Runtime Environment (IcedTea7 2.3.7) (7u15-2.3.7-0ubuntu1~12.10.1) OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode)

share|improve this question
    
Have you tried this: www-01.ibm.com/support/docview.wss=swg21407743? Basically try installing libXp, libXmu, and libXtst libraries. –  chester1000 May 7 '13 at 10:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.