Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Currently installing Ubuntu 12.04.2 Server and I get an error saying it can't detect my network interface device.

My board is Gigabyte Z77MX-D3H-TH.

The installer allows me to continue though. Is there a way to resolve this later on? I tried googling the issue but couldn't find anything substantial.

Thanks.

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

I found something that might just help you out right here on askubuntu! How do I install drivers for the Atheros AR8161 Ethernet controller?

share|improve this answer
    
Hi, thanks for the link as I found out that I had exactly the AR8161 controller. However, I'm still a noob about this whole installation thing and I can't figure out one thing about the instructions there - how do I do apt-get when my network card isn't configured? No internet! My guess is to do this from another machine. But how do I transfer the files to this one then? Hope you can help. Thanks. –  andy u Mar 25 '13 at 2:56
    
I did some more digging and found this: linuxfoundation.org/collaborate/workgroups/networking/alx. I downloaded the tarball, then copied it to a USB, then followed the instructions here (help.ubuntu.com/community/Mount/USB) to manually mount the USB. However, I couldn't get it to mount after the "sudo mount -t vfat..." command. I got an error saying FAT-fs (sdc): invalid media value (0xb9). wrong fs type, bad option, bad superblock on /dev/sdc...Doing fdisk -l returns W95 FAT32 (LBA) as the file system. –  andy u Mar 25 '13 at 3:26
    
After reading through some links...I tried mounting sdc1 instead of just sdc and the thing mounted...hoo boy :) Now to try untarballing... –  andy u Mar 25 '13 at 3:40
    
Ok, I got as far as executing the "make" command. Then I got "The program 'make' is currently not installed. You can install it by sudo apt-get install make." I'm nearing the end of my patience with this. Why wouldn't make be installed by default? –  andy u Mar 25 '13 at 3:57
add comment

You would need to detect the network card from BIOS or by booting via latest ubuntu desktop CD or from a windows boot.

Then try googling for the tar bundle or OEM provided network driver and compile them and check if this work.

See also if the command

lshw -C network

from command line gives more details on the network card.

share|improve this answer
    
Thanks. I found out from this that I indeed had the Atheros AR8161 controller. And Scott provided the link which had a solution for it. –  andy u Mar 25 '13 at 3:42
add comment

I found an easy way to get around this problem. I plugged in an extra LAN card I had lying around, the installer detected it, then I followed the instructions in Scott's link and apt-get installed the additional module for the controller.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.