Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

AMD cedar/ Intel ironlake hybrid graphics. Custom kernel 3.8.3. Free radeon xorg drivers. When I switch from integrated to discrete, I do a killall lightdm and X doesn't automatically respawn like it does under my official ubuntu 3.2 kernel. So I have to sudo lightdm from another vterm. And then, I have NO BACKLIGHT. I can't see my LCD unless I have the sun shining on it. And if I connect it to HDMI tv, I get the tv picture okay and can fanagle to control it from there. But if I set mirroring screens, still no backlight, so I can't see what my laptop is (or is not) displaying.

share|improve this question
    
The backlight is OFF. Not just way low. It can not be turned up again, until I switcheroo back into the integrated graphics. –  user108754 Mar 22 '13 at 22:41

2 Answers 2

I know it doesn't solve my problem by fixing it.

It appears to be a kernel bug that is new since at least 3.7. And anyway wasn't a problem on my 3.6 kernel. There was a fix changelog on the 3.8.5 kernel that may be concerning this but I don't know enough about the kernel to say for sure. In any case, as of 3.8.6, this is an unresolved problem for me.

https://lkml.org/lkml/2013/2/13/680 offers this:

[1.] One line summary of the problem: ATI + I Muxed - vgaswitcheroo - low backlight when switching to ATI [2.] Full description of the problem/report:

This issue started with kernel 3.7.1-17.1. Kernels 3.6.10-3 or earlier are not affected. When switching from the integrated Intel to the discrete ATI, the screen goes dark. Everything else works fine, you can see the screen if you point a flashlight to it. Changing the brightness with the Fn keys or by sending a value directly thru the /sys/class/backlight branch has no effect. Switching back to the Intel GPU makes the screen visible again. Suse's desktop kernel and vanilla kernels have the same issue.

Have tried adding acpi_osi=Linux and acpi_backlight=vendor (or legacy) but made no difference.

share|improve this answer

I have this same problem, and I can confirm that it started somewhere around kernel 3.7. Manually echoing values to /sys/class/backlight doesn't work, but if I have a separate VGA display it will remain on.

It is possible to make the display panel come on by powering on the integrated graphics card and restarting X. You try the following:

  1. If you have an SSH server running you may log in remotely in that way, otherwise switch to VT1 by pressing Ctrl+Alt+F1, entering your username, entering your password, and striking enter (without a flashlight you may be performing this blindly).
  2. echo ON > /sys/kernel/debug/vgaswitcheroo/switch
  3. sudo restart gdm (you will probably be prompted for your password).

Until the kernel bug is fixed you will need to leave your integrated graphics running if you want to use the discrete card.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.