Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After running a Juju environment for some time, now machine 0 has got status: "agent-state: not-started" that has persisted for some time now and it is unable to deploy any new machines.

"Juju ssh 0" gives Waiting for machine to come up". I have also tried rebooting it from Amazon EC2 console without any change.

What do I do to to get it up again?

share|improve this question
    
I am able to log into the machine using "ssh ubuntu@[public IP]", and /var/log/juju/machine-agent.log says: Failure: txzookeeper.client.ConnectionTimeoutException: could not connect before timeout Same error in /var/log/juju/provision-agent.log in addition to: "2013-03-25 11:00:46,661: juju.agents.provision@INFO: Stopping provisioning agent" –  Marius K Mar 25 '13 at 11:03
    
Zooinspector also works from machine 0. –  Marius K Mar 25 '13 at 13:10

1 Answer 1

Seems like I experienced the following bug: https://bugs.launchpad.net/juju/+bug/995823

Workaround is to run "restart juju-machine-agent" after ssh-ing into it directly using "ssh ubuntu@[public IP]", where public IP is found from the machine list ("juju status").

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.