Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had installed ubuntu 11.10 on virtualbox 4.1.8 over windows 7(64-bit, graphics card ATI Radeon HD 5470) as the host. I was trying to run opengl es programs on ubuntu wherein I faced an error during execution:-

OpenGL Warning: Enable 3d acceleration on your VM. Segmentation Fault

I went to the Display options of my VirtualBox and found 3d acceleration to be disabled. I didn't knew that OpenGL required 3d acceleration to be enabled while installing ubuntu setup and missed doing the same. Now I am unable to Enable it from virtualbox and also I am unable to run Opengl exe's on ubuntu. Kindly help on the same.

share|improve this question
    
First stop the VM then you will be able to enable it. –  Web-E Mar 22 '13 at 11:30
    
I stopped the VM, saved the state and came out of it and tried to enable but the state being disabled I am not able to enable it –  user142505 Mar 22 '13 at 11:34
    
not sure, I usually shut it down. By stop I meant to say shutdown. –  Web-E Mar 22 '13 at 11:37
    
Thanks for your reply. I was able enable this time but it threw me following error:- On the Display Page, you enabled 3D acceleration, however 3D acceleration is not working on the current host and you will not be able to start your VM ... –  user142505 Mar 22 '13 at 12:10

1 Answer 1

After having shutdown the guest OS in virtualbox we may enable 3D acceleration from the machine settings:

enter image description here

A guest Ubuntu also needs the guest additions for a virtual 3D graphics driver:

After having installed the guest additions the guest OS needs a reboot for the virtual driver to be loaded.

Troubleshooting:

If this failed we may try to reinstall guest additions, and watch out for errors we may get when doing so. Older versions of Virtual Box may be incompatible with either the graphics drivers from the host, or with the guest Ubuntu version. We then have the following options we may have to install a newer version:

In case it still does not work as expected, and we may not have a graphical desktop we may update our OS from the command line as follows:

  • Update the guest operation system from command line (hold left Shift key on booting to enter a root shell) and then run:

    apt-get update && apt-get dist-upgrade
    
  • we may have to install the guest additons again.
  • Reboot the VM after an OS update
share|improve this answer
    
I was able enable this time but it threw me following error:- On the Display Page, you enabled 3D acceleration, however 3D acceleration is not working on the current host and you will not be able to start your VM ... –  user142505 Mar 22 '13 at 12:54
    
Of course you need to enable your GPU in the host to be able to use it in the guest. Some host drivers may have issues however. –  Takkat Mar 22 '13 at 13:09
    
I tried to check in the ATI Catalyst Center. but didn't get the option to "Enable GPU", does that mean that my graphics card does not support 3D gaming applications? –  user142505 Mar 25 '13 at 12:42
    
I have zero experience with ATI drivers, and how to enable 3D on Windows. But this may be the issue you have here. –  Takkat Mar 25 '13 at 12:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.