Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed node v0.10.1 but now when I run bower install I got this error:

bower extracting /tmp/bower-bootstrap-233205yl5tjk/index.zip

/usr/local/lib/node_modules/bower/node_modules/tmp/lib/tmp.js:219
    throw err;
          ^
TypeError: undefined is not a function
    at Until.PullStream._flush (/usr/local/lib/node_modules/bower/node_modules/unzip/node_modules/pullstream/pullstream.js:112:5)
    at Until.<anonymous> (_stream_transform.js:131:12)
    at Until.g (events.js:175:14)
    at Until.EventEmitter.emit (events.js:117:20)
    at finishMaybe (_stream_writable.js:332:12)
    at endWritable (_stream_writable.js:339:3)
    at Until.Writable.end (_stream_writable.js:326:5)
    at /usr/local/lib/node_modules/bower/node_modules/unzip/lib/parse.js:282:25
    at process._tickCallback (node.js:415:13)

so i did some googling and find out that i need to install node v0.8 instead of v0.10. how can I do that, because when I run this:

$ aptitude show node
Package: node
State: not installed
Version: 0.3.2-7.1
Priority: optional
Section: universe/hamradio
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: i386
Uncompressed Size: 299 k
Depends: libax25 (>= 0.0.11), libc6 (>= 2.7), zlib1g (>= 1:1.1.4), update-inetd, openbsd-inetd | inet-superserver
Description: Amateur Packet Radio Node program
 The node program accepts TCP/IP and packet radio network connections and presents users with an interface that allows them to make gateway connections to remote hosts using a

and this:

$ aptitude show nodejs
Package: nodejs
State: installed
Automatically installed: yes
Version: 0.6.12~dfsg1-1ubuntu1
Priority: extra
Section: universe/web
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: i386
Uncompressed Size: 2,473 k
Depends: libc-ares2 (>= 1.7.3), libc6 (>= 2.6), libev4 (>= 1:4.04), libgcc1 (>= 1:4.1.1), libssl1.0.0 (>= 1.0.1), libstdc++6 (>= 4.1.1), libv8-3.7.12.22, zlib1g (>= 1:1.1.4)
Conflicts: node
Description: Node.js event-based server-side javascript engine
 Node.js is similar in design to and influenced by systems like Ruby's Event Machine or Python's Twisted.

 It takes the event model a bit further - it presents the event loop as a language construct instead of as a library.

 Node.js is bundled with several useful libraries to handle server tasks : System, Events, Standard I/O, Modules, Timers, Child Processes, POSIX, HTTP, Multipart Parsing, TCP,
 DNS, Assert, Path, URL, Query Strings.
Homepage: http://nodejs.org/

So how can I install node v0.8.
Thanks in advance.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

For anyone having this problem, I end up installing nvm through:

npm install nvm

And then used nvm to install node v0.8:

nvm install v0.8.1

And that solved the problem for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.