Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an external drive that apparently won't automount anymore. If I didn't want to restart the machine. Is there a way to automount the drive.

It shows up under /dev/sdb1 if I do:

fstab -l

share|improve this question
    
If you think it should automount, find the reason why it doesn't, and if there is a problem, solve it. –  mikewhatever Mar 22 '13 at 1:05
add comment

2 Answers

up vote 1 down vote accepted

I wouldn't call it "automounting" but you can manually mount the drive. try making a directory for it to mount to:

    sudo mkdir /media/name_of_drive

Then mount it with

    sudo mount /dev/sdb1 /media/name_of_drive
share|improve this answer
add comment

From man page of mount:

mount -a [-t type] [-O optlist]

(usually given in a bootscript) causes all filesystems mentioned in fstab (of the proper type and/or having or not having the proper options) to be mounted as indicated, except for those whose line contains the noauto keyword. Adding the -F option will make mount fork, so that the filesystems are mounted simultaneously. When mounting a filesystem mentioned in fstab or mtab, it suffices to give only the device, or only the mount point.

The programs mount and umount maintain a list of currently mounted filesystems in the file /etc/mtab. If no arguments are given to mount, this list is printed.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.