Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I followed the instructions to install spotify as on various forums & sites, pretty much the same steps everywhere. But when I get to the install spotify line, this is what happens:

The following packages have unmet dependencies:
 spotify-client : Depends: libgconf2-4 but it is not installable
E: Unable to correct problems, you have held broken packages.

What is libgconf2-4 and how do I fix this?

share|improve this question
2  
Welcome to Ask Ubuntu! Take a look at How do I resolve unmet dependencies? In that post you should find a solution for your problem. If you still have troubles, or if you did solved the issue, let us know by creating a new comment here. –  Lucio Mar 22 '13 at 0:09
add comment

2 Answers

I had the exact same problem. What's wrong here is that Spotify cannot run without the package libgconf2-4. This is because Spotify depends on that package. It would be like running an application like Minecraft without previously installing the package libgconf2-4. You can download libgconf2-4 from here.

Get the package according to what version of Ubuntu you have. After you install libgconf2-4, Spotify should install, and you can get to your music!

share|improve this answer
add comment

Installing Spotify

The first step is to open Software Sources via the Unity Dash:

enter image description here

Select the ‘Other Software’ tab in Software Sources 1

enter image description here

Click ‘Add’ 2 and paste the following the entry field of the box that appears:

  deb http://repository.spotify.com stable non-free

Click ‘Add Source’ to confirm the change, then close Software Sources.

Add Spotify Repo Key

The next step is to add the repository key to verify that packages installed from this PPA are by whom they say.

Open a new Terminal window

Paste the following, then hit return/enter:

 sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 94558F59

That’s that! You can now install Spotify through the Ubuntu Software Center (after checking for software updates first) or by running the following command in the Terminal window:

 sudo apt-get update && sudo apt-get install spotify-client

Once installed you can launch Spotify from the Unity Dash.

Source : OMG Ubuntu

A sneak peek into Spotify's secret labs

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.