Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ok. so I know there are about a million threads on this subject already, but NOTHING has worked for me. About to lose my mind here, if someone can please help I will be eternally grateful.

I have a Dell Inspiron E1505 which has a Broadcom Corporation BCM4311 wireless controller. I can't get it to work.

I've followed the steps outlined on the following sites:

How can I get Broadcom BCM4311 Wireless working?
http://ubuntuforums.org/showthread.php?t=2072887
https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper

and more. Nothing is working, and I'm on the verge of giving up. As a Linux newbie I can only imagine I'm missing something stupidly obvious. If someone could give me a step-by-step instruction for going from a completely fresh 12.10 install to having a working wifi connection I would be (as mentioned earlier) eternally grateful. Please let me know if anyone needs more info.

share|improve this question
    
Seems like all you need is sudo apt-get install firmware-b43-installer b43-fwcutter to install the driver, and reboot. Needless to say, you'll need a wired connection for the command to work, and in case there are any errors, post them. –  mikewhatever Mar 21 '13 at 23:59
    
@mikewhatever: just did a fresh install, ran that line on terminal and got no errors. Unplugged ethernet, rebooted -- nothing. if I run iwconfig I get: lo no wireless extensions, eth1 no wireless extensions. I've tried hitting the Fn+F2 key which is supposed to turn wireles on and off and it makes no difference. Any other ideas? –  Jason Hamje Mar 22 '13 at 1:57
    
Check if the b43 module is loaded: lsmod | grep b43. If not, load it with sudo modprobe b43. If you want serious help, please add the output of lsmod and lspci to the question. –  mikewhatever Mar 22 '13 at 2:58
    
Also make sure your hardware switch it in the "On" position. –  Seth Mar 22 '13 at 3:09
    
Please run lspci -vvnn -d 14e4: and confirm that the pci-id of the chip is NOT [14e4:4313] According to wireless.kernel.org/en/users/Drivers/b43 That chip takes the wl driver and not the b43. –  ubfan1 Mar 22 '13 at 3:40

1 Answer 1

up vote 1 down vote accepted

On a clean install, connect an ethernet cable, open a terminal window, and run

sudo apt-get install firmware-b43-installer b43-fwcutter

Then run echo b43 | sudo tee -a /etc/modules to make sure the module is autoloaded. Reboot, and if all goes well, the wireless should work.

share|improve this answer
1  
thanks again, sir. eternal gratitude. Hope someone else finds this useful as well –  Jason Hamje Mar 22 '13 at 15:18
    
Most welcome, glad I could help. –  mikewhatever Mar 22 '13 at 16:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.