Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.10 and I usually start firefox by the command line and after an upgrade I noticed that I am getting these errors. I don't see many posts about them from others, so I have very little to go by as far as to how to fix them. Has anyone else seen this error, and if so what did you do to fix it?

gserver@gserver:~$ firefox

(firefox:22346): Gtk-CRITICAL **: IA__gtk_settings_set_long_property: assertion `GTK_SETTINGS (settings)' failed

(firefox:22346): Gtk-CRITICAL **: IA__gtk_settings_set_long_property: assertion `GTK_SETTINGS (settings)' failed

(firefox:22346): Gtk-CRITICAL **: IA__gtk_settings_set_long_property: assertion `GTK_SETTINGS (settings)' failed

(firefox:22346): Gtk-CRITICAL **: IA__gtk_settings_set_long_property: assertion `GTK_SETTINGS (settings)' failed

(firefox:22346): Gtk-CRITICAL **: IA__gtk_settings_set_string_property: assertion `GTK_SETTINGS (settings)' failed

(firefox:22346): Gtk-CRITICAL **: IA__gtk_icon_theme_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed

(firefox:22346): Gtk-CRITICAL **: IA__gtk_icon_theme_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed

(firefox:22346): Gtk-CRITICAL **: IA__gtk_icon_theme_prepend_search_path: assertion `GTK_IS_ICON_THEME (icon_theme)' failed

(firefox:22346): Gtk-CRITICAL **: IA__gtk_icon_theme_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed

(firefox:22346): Gtk-CRITICAL **: IA__gtk_icon_theme_prepend_search_path: assertion `GTK_IS_ICON_THEME (icon_theme)' failed

(firefox:22346): Gtk-CRITICAL **: IA__gtk_icon_theme_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed

(firefox:22346): Gtk-CRITICAL **: IA__gtk_icon_theme_prepend_search_path: assertion `GTK_IS_ICON_THEME (icon_theme)' failed

How can I fix/adjust my GTK_SETTINGS?

TIA

Matt

share|improve this question
    
I needed to add GTK2_RC_FILES=/usr/share/themes/Ambiance/gtk-2.0/gtkrc to ~/.bashrc. I am still getting errors so there are probably more environmental variables missing. –  Matt Thornton Mar 22 '13 at 0:51
    
Anybody else experience this problem? –  Matt Thornton Mar 26 '13 at 19:34
add comment

1 Answer 1

See if the line

include "/usr/share/themes/oxygen-gtk/gtk-2.0/gtkrc"

is located in your ~/.gtkrc-2.0 file, and try removing it. This worked for me. The only line now in my ~/.gtkrc-2.0 is

gtk-theme-name="oxygen-gtk"

share|improve this answer
    
No the only include files that I see are include "xfce.rc", include "menubar.rc", and include "chrome.rc" –  Matt Thornton May 3 '13 at 20:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.