Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Problem: I can't adjust the brightness of my iMac and it's killing me. (My eyes! The goggles do nothing!).

Has anyone gotten this to work?

-Booting with rEFIt 0.14

-Product Name: iMac12,2

-Kernel: 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

I've tried this fix: https://wiki.ubuntu.com/Kernel/AppleGmuxBacklight

But it doesn't seem to work since the kernel module doesn't seem to be loading. (dmesg | grep gmux returns nothing)

I've also tried doing this:

xrandr --output LVDS --brightness 0.3

and it dims the screen, but the mouse cursor still blazes away at full brightness.

Any thoughts? Thanks!

UPDATE:

Performing ls /sys/class/backlight/ returns acpi_video0

-The brightness slider in "System Settings" has no effect.

-The "brightness" function keys on my apple bluetooth keyboard don't have any effect.

Thanks!

share|improve this question

closed as off-topic by bain, Eric Carvalho, Warren Hill, Sneetsher, bodhi.zazen Jul 14 at 21:43

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – bain, Eric Carvalho, Warren Hill, Sneetsher, bodhi.zazen
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Can you ls /sys/class/backlight/ –  Symin Mar 21 '13 at 18:16
    
If I perform that, I get: acpi_video0 That's it. –  PopeJamal Mar 21 '13 at 22:00
    
You are not using external monitor, right? –  Symin Mar 22 '13 at 19:08

3 Answers 3

Right,

I don't know if you tried this, but:

  1. You could use the FN keys

or,

  1. Just edit the brightness in System Settings!

Hope this helps!!

share|improve this answer

I have never used this gmux thing, but it looks like it is a dynamic kernel module. Are you sure you didn't have any errors while installing it?

Remove the module:

sudo modprobe -r apple_gmux

Uninstall it:

sudo apt-get remove apple-gmux-dkms --purge

Run update:

sudo apt-get update

Check your kernel version:

uname -a

e.g

Linux MarsBox 3.5.0-26-generic #42-Ubuntu SMP Fri Mar 8 23:18:20 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Make sure the kernel headers are installed for your kernel

sudo apt-get install linux-headers-3.5.0-26-generic

Install the gmux again

sudo apt-get install apple-gmux-dkms

Enable module

sudo modprobe apple_gmux

Check if it works.

share|improve this answer

Have you tried adjusting the acpi_video0 with a terminal?

To check max value you can use run:

cat /sys/class/backlight/acpi_video0

To check current brightness:

cat /sys/class/backlight/acpi_video0/brightness

To change brightness (input between 0 and your max_brightness):

echo YOUR_BRIGHTNESS_HERE | sudo tee /sys/class/backlight/acpi_video0/brightness

If this doesn't work perhaps your bootloader is messing something up or this video driver doesn't work on your machine.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.