Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

By default In Ubuntu I can perform SHIFT+HOME to select content from caret to start of string, while NUMLOCK is turned off. But if in that case I press just HOME, it will type 1 instead of moving caret to start of string, and this is expected behavior considering that NUMLOCK is off. To use HOME I will need to turn on NUMLOCK.

So - how can I change it to Microsoft-defaults, when perform SHIFT+HOME and HOME doesnt need changing state of NUMLOCK?

Ive already discovered this q: XUbuntu: Make Shift+NumPad work like Windows

But it does not help. My /etc/default/keyboard file looks now:

# Check /usr/share/doc/keyboard-configuration/README.Debian for
# documentation on what to do after having modified this file.
# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.

XKBMODEL="pc105"
XKBLAYOUT="us"
XKBVARIANT=""
XKBOPTIONS="numpad:microsoft"

# If you don't want to use the XKB layout on the console, you can
# specify an alternative keymap.  Make sure it will be accessible
# before /usr is mounted.
# KMAP=/etc/console-setup/defkeymap.kmap.gz

UPD Also I found that on login screen HOME/SHIFT+HOME works properly!

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.