Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a system that ran cleanly on Ubuntu 10.04 LTS.

Upgrading to 12.04 LTS / 12.04.1 LTS / 12.04.2 LTS has been unpleasant and unsuccessful.

Install goes cleanly and I have installed as follows:

  1. / on lvm lv backed by by mdadm RAID 1 pair /dev/md0 (/dev/sda1, /dev/sdb1) ext4 0.90 metadata
  2. /boot on LVM lv backed by mdadm RAID 1 pair /dev/md1 (/dev/sda2, /dev/sdb2) ext4 0.90 metadata
  3. swap on LVM lv backed by mdadm RAID 1 pair /dev/md2 (/dev/sda3, /dev/sdb3) swap 0.90 metadata
  4. /data on LVM lv backed by mdadm RAID 5 set /dev/md3 (/dev/sd[cdefghijkl]1) XFS 1.2 metadata

After install I boot for the first time from the system. I get the grub2 menu and can pick either normal or recovery mode and the behaviour is the same:

It seems that my second disk controller is slow to start up and/or mdadm takes a bit longer to assemble /dev/md3 and this is detected as a failure.

Even though I (try to) respond affirmatively to the 'start degraded array' prompt, I always land in the busybox prompt.

If I start in recovery mode I see /dev/md3 boot up completely after the system has moved past the 'start degraded array' prompt.

I see that there are issues with 12.04, one post captioned this way: DANGER - DO NOT USE UBUNTU 12.04 IF YOU HAVE ANY SOFTWARE RAID

ubuntuforums.org post 1983352

ubuntu bug 872220

Is the problem solved in 12.10, or are there other workarounds available?

thanks for any suggestions... Brad

share|improve this question
    
Fresh install of Ubuntu 12.10 server amd64 exhibits same behaviour. very disappointing :( –  Brad Mar 22 '13 at 23:33
    
I'm sorry to see that your upgrade has gone wrong. Luckily my upgrades of MDADM arrays has always worked. What hardware are you using? If it is an onboard SATA controller, is it set to AHCI mode in the BIOS? –  ph0t0nix Nov 4 at 9:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.