Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

my notebook is HP ProBook 4530s-LH306EA. I have two video cards discrete(AMD Radeon HD 6490M) and integrated.

Today I have installed Ubuntu 12.10, and meet the problem that my computer become very hot (jupiter shows from 75-85 degrees). I have understand that the problem in video card, so I have tried to switch off discrete using But I don't know how to switch it forever, because after computer restarts discrete is switched on.

And I cannot understand why there is so big problem with this video cards? On windows exists program, that knows which of this two video cards to use.

PS I have missed step with backup and start installing, but then occure error: "One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver. Optionally, run the installer with --force option to install without the tools. Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended. See /usr/share/ati/fglrx-install.log for more details"

In log file is written: "Check if system has the tools required for installation. fglrx installation requires that the system have kernel headers. /lib/modules/3.5.0-17-generic/build/include/linux/version.h cannot be found on this system."

PSS I have run with --force option and get: Supported adapter detected. Check if system has the tools required for installation. fglrx installation requires that the system have kernel headers. /lib/modules/3.5.0-17-generic/build/include/linux/version.h cannot be found on this system. fglrx installation is being forced. Installation will proceed without the required tools on the system. Uninstalling any previously installed drivers. Unloading radeon module... ERROR: Module radeon is in use Unloading drm module... ERROR: Module drm is in use by radeon,i915,ttm,drm_kms_helper [Message] Kernel Module : Trying to install a precompiled kernel module. [Message] Kernel Module : Precompiled kernel module version mismatched. [Error] Kernel Module : Kernel module build environment not found - please consult readme. [Reboot] Kernel Module : update-initramfs

share|improve this question
up vote 0 down vote accepted

If you cannot install/use AMD Catalyst Driver (like me) either from Ubuntu repositories or manually from their website, you can automatically turn the discreet graphics on and off when you switch between AC and Battery power supply by simply adding a small executable script file named 11_hybrid_graphics_switch into the folder /etc/pm/power.d with the following contents:

if on_ac_power; then
    echo ON > /sys/kernel/debug/vgaswitcheroo/switch &
    echo OFF > /sys/kernel/debug/vgaswitcheroo/switch &
exit 0

For more info, see my answer at: Error Creating .deb File of AMD Catalyst Driver

share|improve this answer
nice solution. but I would prefer to fully disable discrete card. Will this script work if in third line I write echo OFF? And what will happen when I start computer? – kobra Mar 21 '13 at 16:36
If you are sure about it, replacing "ON" with "OFF" in the 3rd line should give the result you want, but I think in that case there should be a simpler way of doing it, e.g. simply adding the 5th line in one of the startup scripts, e.g. rc.local? – Sadi Mar 21 '13 at 17:54
ok, thank you for the help. How do you thing this bug with drivers will be solved in future? – kobra Mar 21 '13 at 18:09
I personally don't know. It seems the proprietary drivers don't work well under Ubuntu 12.10. Perhaps the card manufacturers can develop their Linux driver better in the course of time. – Sadi Mar 21 '13 at 19:04

I suggest you to use AMD Catalyst Driver. You can switch between AMD Graphics or Integrated graphics graphically. This is the link for the tutorial: BinaryDriverHowto/ATI. Read section 3.2, hope that help you.

share|improve this answer
I have tried to install it, but at the first step occur errors, there is no file /etc/X11/xorg.conf – kobra Mar 21 '13 at 10:29

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.