Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I keep receiving a crash report and when I view the details it says xserver-xorg-video-intel not installed. I receive this crash report constantly. 5-10 times in a row. It is very annoying and I need to find a way to stop this. I am using Ubuntu 12.04 clean install.

If I try to install (sudo apt-get install xserver-xorg-video-intel), it says

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xserver-xorg-video-intel : Depends: xorg-video-abi-11
                            Depends: xserver-xorg-core (>= 2:1.10.99.901)
E: Unable to correct problems, you have held broken packages.
share|improve this question

3 Answers 3

the graphics gui by intel helped me. My bug seems to be related to my graphic card sandybridge. Here is the launchpad bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1140716

share|improve this answer
up vote 2 down vote accepted

There is a graphics gui by intel for download.

sudo apt-get install intel-linux-graphics-installer

However, it is for the 32bit system but if you install on a 64, your touchpad mouse will become unresponsive. You can then do

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get upgrade

This fixed the xserver crashes and the mouse wasn't disabled after every reboot. If your mouse is disabled, do

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

But after re-downloading from the ppa, the issue resolved with the touchpad.

share|improve this answer

sudo apt-get check will "verify there are no broken dependencies." - man apt-get

Try that and sudo apt-get install -f. That will try to fix these broken dependencies. If it doesn't solve the problem please post the output of the commands.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.