Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

System info: Dell XPS 8500 SE with 2TB HD and 32GB SSD SATA RAID cache

I have been at this project for a couple days now and have hit a brick wall on researching the issue. I can't find an instance of my configuration online as all of the posts that I've found are a little bit different than mine and the solutions haven't worked for me.

I know exactly what the problem is but I don't know how to solve the issue on the Linux platform. I am very new to Linux and need some expert help!

When I bought my machine last October, I had the same issue when setting up a dual-boot for windows 7 and windows 8. The problem was there wasn't any visibility to the drives because the windows installer didn't contain the proper drivers for my SATA RAID cache.

I solved the previous issue by storing the driver, Intel(R) Desktop/Workstation/Server Express Chipset SATA RAID Controller, to a USB and loading this driver at the windows 8 install session.

How can I load these same drivers at the time of Ubuntu install? I have tried installing both from CD and also the wubi.exe from Ubuntu. When installing with wubi.exe, I am presented with the dialog box that asks me to set the install location and create a new user but after the install reboots to complete, I am presented with an error that says no root file system was detected.

When installing from the CD, none of my physical drives are present on the partition table list so I am unable to complete the install. If I plug in an external drive it becomes available so I know the issue is with my hard drives not being detected due to the RAID controller.

To solve the issue with installing from CD, I entered the busy box (ctrl + alt + f2 ) as soon as the computer rebooted from install so that I can mount the USB with the drivers and copy the .sys files for the drivers to the kernel. I am able to mount and "cp" the data just fine, but after returning to ctrl + alt + f1 I don't know how to continue with the install.

I think I may be able to solve the issue if anyone knows how to make the install continue after the drivers have been copied to the kernel. However, as stated, I am new to Linux and I am unsure if this is even a valid approach. Please give me some insight on how I can re-approach the problem, I am out of ideas.

Boot Repair log

share|improve this question
I was able to get ubuntu to install by running the installer in windows 7 instead of windows 8. On the initial Ubuntu boot everything was great. I was presented with the log in screen and logged in with no problem. After rebooting, I am given the option to select my OS and if I choose ubuntu it boots to the grub menu. Can I start ubuntu from there? – Jesse Nelson Mar 21 '13 at 1:56
I apologize. I didn't know this report was a possibility, but here is the report generated by boot repair. Thanks – Jesse Nelson Mar 21 '13 at 3:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.