Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I'm trying to install Ubuntu 12.10 on my Acer Aspire at work. I need to keep the original Windows 8 and would like to have Ubuntu running alongside it. So far I've only been able to get the Ubuntu live to boot when in legacy mode, which doesn't work with my UEFI Windows 8.

I've tried disabling and enabling secure boot as well, but it doesn't appear to change much. I've tried using the secure-remix as well, but it doesn't appear to recognize the disk (problem with the iso maybe?).

After looking around I've yet to find anything that helps me get Ubuntu running on this machine. I don't want to install ubuntu in legacy mode for fear of destroying Windows 8.

Any help would be greatly appreciated.

share|improve this question

marked as duplicate by Eliah Kagan, Kevin Bowen, Seth, Mitch, AgentCool Mar 29 '13 at 11:46

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
What happens when you try to boot in EFI mode? For that matter, how are you attempting to boot in EFI mode (that is, what keys are you pressing or menu options are you selecting to enable an EFI-mode boot, and what type of media are you using)? –  Rod Smith Mar 21 '13 at 0:28
    
One more question: Are you trying to install the 64-bit or 32-bit version of Ubuntu? On most EFI-based computers, the 32-bit version will install only in legacy/BIOS mode, not in EFI mode; on such systems, you must install the 64-bit version of Ubuntu. –  Rod Smith Mar 21 '13 at 0:35
    
I'm fairly certain that I'm using the 64bit version, it just doesn't seem to want to boot into UEFI mode. I get the correct grub bootloader screen on boot, but after that the screen is black and the media (CD or USB) is not being accessed after that point. In the Acer Bios (I'll get the version number if you want) I set to start in UEFI (disabled CSM), disabled secureboot (enabling it doesn't change anything) and turned fastboot off within windows 8. I also set the boot order when I want to boot into Ubuntu live within the bios so it loads the media device desired first. Should i try 12.04 –  David Mar 21 '13 at 14:33
    
I also have an AMD Radon HD 6530D video card (The computer has an AMD A6-3260 APU), could it be a video card issue? Thanks for the help! –  David Mar 21 '13 at 14:42
    
I've also tried using different options for grub, such as nomodeset, acpi=off, nolapic. –  David Mar 21 '13 at 15:39

1 Answer 1

If you can boot the installer in BIOS/CSM/legacy mode, you could try a BIOS-mode installation. That will leave you with a mixed-mode setup, though -- with Windows booting in EFI mode and Ubuntu in BIOS mode. This is likely to be awkward, since you'll need to use the firmware's built-in boot manager to select the boot mode, at least initially. There are ways to make it work:

  • You could install rEFInd, edit its refind.conf file to uncomment the scanfor line, and add hdbios to that line. This will enable rEFInd to boot a BIOS-mode boot loader on at least some systems. This isn't guaranteed to work, but if it does, you'll then be able to boot the computer in EFI mode, which will launch rEFInd, from which you'll be able to launch Windows or a generic entry for GRUB. The latter will launch Ubuntu in BIOS mode.
  • You could install any EFI-mode boot loader for Linux you like. When you boot in EFI mode, this will then enable you to boot Linux, and some (such as GRUB and rEFInd) will enable you to boot Windows, too. Given your current problem, though, this might not work at all. Note that rEFInd is one possible EFI-mode boot manager, so you can use it for the preceding method and then try a more direct boot using rEFInd, too. To get it to boot Ubuntu directly, you'll need to add a filesystem driver so that it can read your kernel and create a /boot/refind_linux.conf file. (This is all described in the rEFInd documentation.)
  • You could convert Windows to boot in BIOS mode. This is likely to be quite awkward, though; you'll need to convert from GPT to MBR partitions and then either re-install Windows or jump through some poorly-documented hoops to switch Windows to use a BIOS-mode boot loader.

All of this assumes a successful BIOS-mode Linux installation. It's entirely possible that you're running into a hardware problem (hardware that lacks a Linux driver), in which case your only hope for installing Linux is to dig up a new driver and patch the installer with it or to wait until such a driver makes it into a future version of Ubuntu (or some other distribution).

share|improve this answer
    
Thanks Ron! I think this will give me plenty of playing around with the computer. I might just try contacting Acer and see if they have any thoughts. –  David Mar 21 '13 at 21:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.