Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem installing Ubuntu via USB storage using unetbootin: My notebook BIOS does not read the USB key, instead of another notebook that I tried that does.

I think the problem is that USB ports are not active because if I go in BIOS settings in the page in which I can set what device is ran first, the bios does not show me the name of the USB drive, instead of the other notebook that does.

share|improve this question
up vote 0 down vote accepted

Look for something called USB Legacy Support in the BIOS or similar. Enabling that should allow the machine to pretend the USB key is a hard drive and boot from it. Ubuntu should take over from there.

share|improve this answer
Right answer!! Thank you and thank everybody tried to help me! – user142088 Mar 21 '13 at 15:41
You're welcome :) – RandomInsano Mar 22 '13 at 1:16

Are you shure, that your BIOS supports booting from USB?

If your BIOS does not list USB, make shure you pluged in your device BEFORE starting your laptop.

Do you have UEFI? Maybe this is your problem.

Maybe this site will help you.


Maybe you have to activate your USB device in the BIOS, search for "Inegrated Peripherals"

share|improve this answer
i am quite sure that does support it because there are listed 3 usb options, like in my other notebook, such as the one that is used that is called usb hdd .. – user142088 Mar 20 '13 at 21:22
i can't find anything like integrated peripherals :/ – user142088 Mar 20 '13 at 21:33
if i go in boot section, i can see some choices: – user142088 Mar 20 '13 at 21:33
the first one is called boot device priority, i go there, there is the list of the devices launched in order of priority, but usb hdd does not have nothing written on the right, instead of the hard disk and the dvd reader that have respective names on the right.. – user142088 Mar 20 '13 at 21:37

Maybe that computer doesn't like the way your software boots [I've had that problem before] there's a lot of good software for booting Linux from USB at [all free!]

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.