Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have to use LXDE because of the age of my system, and I quite like it. But after I changed the default file manager from PCManFM to Nautilus (via this) and restarted, I just get a background color and some of the logos; even then, some of the logos are different than the typical LXDE logos.

It says LXPanel is running when I run task manager (Ctrl + Alt + Delete) and when I try to run it from terminal (Ctrl + Alt + T) it says that it is already running.

If I kill LXPanel via terminal and run the command sudo lxpanel it will run, but only as long as the command is running in terminal and even then the logos are weird on the panel too.

The original install was done via sudo apt-get install lubuntu-desktop, so hopefully that helps. I had some default LXDE programs installed and the LXDE DE.

EDIT:

I simply ran the command sudo apt-get purge lubuntu-desktop and sudo apt-get purge lxde and then reinstalled it via sudo apt-get install lubuntu-desktop and sudo apt-get install lxde* (I know about the * and what it does, I wanted it that way.)

Anyways, it works now and I am using it currently. Thanks for the help @vasa1.

share|improve this question
1  
Is there anywhere you've described your original set-up? Was it a vanilla Lubuntu install? Why did you need to run sudo lxpanel and not simply lxpanel? I think you can run something from a terminal and have it running even after closing the terminal like this: nohup lxpanel & –  user25656 Mar 21 '13 at 0:57
    
Oh, my bad. I should have said something about that. –  RPi_Awesomeness Mar 21 '13 at 1:13
    
Yeah, I fixed the post and as you can see, it is working fine now. Thanks for the help! I will stick with PCManFM and just start Nautilus when I need a feature. –  RPi_Awesomeness Mar 21 '13 at 1:17
    
Great! To my mind, the second command wouldn't be needed. Could you elaborate? –  user25656 Mar 21 '13 at 1:19
    
Which second command? The sudo apt-get install lxde*? It wanted to see the extra features that it might come with. –  RPi_Awesomeness Mar 21 '13 at 1:21

1 Answer 1

up vote 1 down vote accepted

I have fixed my problem, I just had to purge and reinstall LXDE and lubuntu-desktop.

Actual commands:

  1. sudo apt-get purge lxde
  2. sudo apt-get purge lubuntu-desktop
  3. sudo apt-get install lubuntu-desktop
  4. sudo apt-get install lxde* (I know what the * option means, I wanted that)

Thanks for the edits and comments @vasa1

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.