I am trying to build webkit from sources and when I launch autogen.sh, I get error:
Requested 'libsoup-2.4 >= 2.40.0' but version of libsoup is 2.38.1 Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix. Alternatively, you may set the environment variables LIBSOUP_CFLAGS and LIBSOUP_LIBS to avoid the need to call pkg-config. See the pkg-config man page for more details.
sudo apt-get install libsoup2.4-1
But version remained the same:
dpkg -s libsoup2.4-1 Version: 2.38.1-1
How to get newer version?
Using Ubuntu 12.04