Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I seem to have lost the lock screen option for one user of the system. It does not appear in the menu in the top right hand corner (with Log Out etc) and nor does Ctrl+Alt+L do anything despite being listed in the keyboard shortcuts of my system settings to lock screen. If I go to Brightness and Lock the lock area is just greyed out.

This facility is available to other users on the system so I'm not quite sure what the problem is. I should note that this particular user is not an admin user and does not have sudo privileges whereas the user is works for does (just in case that is important).

I can't remember if I perhaps turned this facility off a long time ago for this user, but if so now I don't seem to be able to get it back.

Some things I've tried:

Removed xscreensaver, re-installed gnome-screensaver (currently the newest version)

Set gsettings set org.gnome.desktop.screensaver lock-enabled true

I created a new test user with no admin privileges and for them the lock screen option was available.

share|improve this question
    
Please make a test: create a new "normal" user and see if the lock-screen is enabled there. (and edit your question to tell us the result :-)) –  guntbert Mar 20 '13 at 21:08
    
@guntbert I did as you asked and put result in my OP. The new test ``normal'' user did have lock screen availability. –  fpghost Mar 20 '13 at 21:36
    
So it looks like its a setting just for one user, not a system problem, no idea how to find that - sorry. –  guntbert Mar 21 '13 at 17:26
    
got the same issue suddenly by upgrading from 14.04 to 14.10. Affect a single no sudoer user... –  Xavier T. Oct 23 at 9:20

2 Answers 2

In the mean time I got some form of lock capability back by just purging gnome-screensaver reinstalling xscreensaver and adding a custom keyboard shortcut of Ctrl+Alt+L (after disabling the existing one in system) to launch the xscreensaver-command --lock command and lock my screen with that. I still don't have a Lock Screen in the drop down nor can I work out how I got rid of the original lock screen for this user.

share|improve this answer

On my installation, the issue appeared when upgrading from 14.04 to 14.10

Found the solution by looking at another question :

Screen truns off when I lock, but doesn't lock. "Lock" settings grayed out

I don't know why but the Unity Security option had disabled locking and user session on a non sudoer admin. Removing the option reenabled the locking and switching ability.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.