Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is a new installation. I used sudo apt-get install libapache2-mod-auth-mysql phpmyadmin

If i put the following code in my httpd config file I get a 500 Internal Server Error. Any idea why I"m getting this error? Is something wrong with my directory path or password path?

ThiI is httpd.conf:

 <Directory /usr/share/phpmyadmin>
 Options FollowSymLinks
 DirectoryIndex index.php
 # AllowOverride AuthConfig
 AuthType Basic
 AuthName "Restricted Files"
 AuthUserFile /usr/share/password/.htpasswd
 Require valid-user
share|improve this question
up vote 0 down vote accepted

Check your webserver error logs. They should detail the specifics of the 500 error.

share|improve this answer
Wow thanks for the quick reply. That fixed it. The log said: "[Wed Mar 20 12:57:02 2013] [error] [client] (2)No such file or directory: Could not open password file: /usr/share/password/.htpasswd" i changed .htpasswd to .htpassword and it worked. – Jacob Pressures Mar 20 '13 at 18:38
Well, there you go. :P – Thomas Ward Mar 20 '13 at 18:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.