Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

my internet connection does not work properly. I am able to connect to the internet using Software center, but browsing with firefox or chromium does not work.

I've got a wireless usb adapter by D'link (dwa140 revB3). The website where the network drivers are listet says I need an additional driver, but it worked out of the box in Ubuntu 12.10.

Trying to ping google.com or any other website in terminal gives me a never ending list as a result. So this does not work. I also tried to disable IPv6 but this did not help either.

Please help me. Everything else works and I'm not willing to switch back to windows 7. Thanks!

share|improve this question
    
Are you behind a proxy and did you ever set your proxy in "System Settings -> Network"? –  Jobin Mar 20 '13 at 14:56
    
Thanks for your reply. Neither am I behind a proxy nor did I set it up. –  Miró Whoongabonga Mar 20 '13 at 14:59
    
Does ping fail, or does it get replies? What are the outputs of lspci | grep -iA2 net and nm-tool | grep DNS. –  mikewhatever Mar 20 '13 at 15:23
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.