Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My question

I am not attached to the splashscreen or whatever. How can I configure a non-graphical boot that still takes me to the login screen? In other words, I do want X to start as the last thing in the boot process, but I do not need any other tools (plymouth or userspace bootsplash or whatever).

My problem

I get a blank/purple screen at undefined times when use the battery or when I have used it. I have a Lenovo Easypad z580. At times the problem also occurs after a suspend. In that case it states something like userspace bootsplash stopped.

My research

I read and tried the solutions in the following pages:

  1. https://wiki.ubuntu.com/X/Troubleshooting/BlankScreen
  2. https://wiki.ubuntu.com/X/Troubleshooting/Freeze
  3. https://wiki.ubuntu.com/X/NonGraphicalBoot
  4. My computer boots to a black screen, what options do I have to fix it?

I already disabled plymouth.

I do not think that this question is a duplicate (because I want a non-graphical boot, yet a graphical desktop). But I might be mistaking. Also my scenario is none of the ones proposed in My computer boots to a black screen, what options do I have to fix it? (If you are trying to install Ubuntu, If you have a dual boot system, If an update or something else caused your problem).

share|improve this question
1  
Do yo tried to start Ubuntu choosing recover mode in grub? Starts without X and you can try to solve your problem installing drivers etc... –  smile Mar 20 '13 at 11:32
    
Hi smile. I am not sure this is a drivers issue. Also recovery mode is not really what I am looking for. –  don.joey Mar 20 '13 at 12:02
    
Just to understand what you want: 1) you want the normal graphical greeter/login, 2) you don't want any graphical gimmicks until lightdm (or whichever display manger) starts. –  guntbert Mar 20 '13 at 17:51
    
Guntbert, that is indeed what I want. –  don.joey Mar 20 '13 at 21:16
add comment

1 Answer 1

sudo nano /etc/default/grub

Uncomment GRUB_TERMINAL="console"

And remove quiet splash from GRUB_CMDLINE_LINUX_DEFAULT

then issue sudo update-grub. This will disable graphical boot.

share|improve this answer
    
will this still startx? –  don.joey Mar 20 '13 at 13:06
    
there will be a text based boot, and it will take you to the lightdm login screen. will this still startx? i don't understand, if you want that startx appearing for login, then you have to disable lightdm. –  wedu Mar 20 '13 at 13:16
    
if you already have startx, then just uncomment the GRUB_TERMINAL="console", (remove the number sign at the beginning) and you are good to go. –  wedu Mar 20 '13 at 14:04
    
Ok that almost gets me there. When booting I now see error: no video mode activated. –  don.joey Mar 21 '13 at 8:31
    
there are many workaround for this bug (no video mode) here bugs.launchpad.net/ubuntu/+source/grub2/+bug/699802. might be an issue with gfxmode, fonts, grub hidden timeout etc –  wedu Mar 21 '13 at 13:06
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.