Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using Maverick, I am not able to get the CapsLock behaviour I want: I would like it to affect essentially the alphabetical, numerical, and punctuation keys, i.e. all the keys that print something (as opposed to, say, the error keys), but only them.

To illuminate this with an example: when writing code that uses % as the symbol for a comment, I want to be able to position the cursor at the start of a range of lines I want to comment out, then hit CapsLock, then iteratively hit the 5 key (using QWERTZ, Shift+5 gives %) and the arrow down key, so that I can quickly place a % at the start of the lines.

Ubuntu in default configuration takes CapsLock literally, so that it affects only alphabetic keys. Under Preferences/Keyboard/Layout/Options I can make it act as a pressed Shift, but then the action of the arrow keys is to select text. All the other options available are equivalent to one of these two in my case.

Is it possible to somehow get this behaviour? This is standard in Windows.

Edit: @Mikel: I use English language with German keyboard layout. Yes, by googling I found out about this Belgian problem and the fix, but I hoped that there was an easier way, as I just want the Windows behaviour. Let's see whether I get it to work.

share|improve this question
2  
What language do you use? You might be able to adapt the solution for Belgian to your needs. launchpadlibrarian.net/29195040/mswindows-capslock.patch –  Mikel Feb 18 '11 at 21:56
1  
^ I'm new here. Why is this a comment instead of an answer? –  djeikyb Feb 19 '11 at 0:16
    
@djeikyb ask that on meta :) –  RolandiXor Feb 19 '11 at 2:16
1  
@Roland It's half rhetorical. That is a comment, admittedly with room for expansion, that I would award as The Answer if I were the questioner. –  djeikyb Feb 19 '11 at 5:25
    
ahh I get you now. The part about being new made me suggest you go to meta :) –  RolandiXor Feb 19 '11 at 12:04

1 Answer 1

Answers in the comment lead to the impression that there is no easy GNOME setting to toggle. Vote up mikel's answer in the comments, not mine: http://launchpadlibrarian.net/29195040/mswindows-capslock.patch to adapt the belgian solution.

share|improve this answer
    
Think the policy is to use answers, not comments, on askubuntu. You can't accept a comment as an answer for example. Mikel should be encouraged to submit his comment as an answer. –  Scaine Feb 19 '11 at 9:30
    
I agree. Hello, Mikel! –  user unknown Feb 19 '11 at 10:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.