Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently installed Ubuntu 12.10 as a dual boot with Windows 7 but I've found my that neither operating systems can detect any of my ethernet cables. Wireless internet does work on both though. My LAN driver is Realtek PCIe GBE Family Controller. Since I'm new to Ubuntu I haven't tried much to fix it on Ubuntu, but I've tried a variety of things on windows like re installing the driver.

Any advice will be appreciated.

share|improve this question

2 Answers 2

download this file:

http://www.orbit-lab.org/kernel/compat-wireless-3-stable/v3.6/compat-wireless-3.6.6-1-snpc.tar.bz2

and write following commands in terminal

tar -xvf compat-wireless-3.6.6-1-snpc.tar.bz2
cd ccompat-wireless-3.6.6-1-snpc
scripts/driver-select alx
sudo make
sudo make install
sudo modprobe alx
share|improve this answer
    
I've tired the following but got stuck at running sudo make in the terminal, it gives:make[1]: Entering directory /lib/modules/3.5.0-26-generic/build' make[1]: *** No rule to make target modules'. Stop. make[1]: Leaving directory `/lib/modules/3.5.0-26-generic/build' make: *** [modules] Error 2 –  user141946 Mar 20 '13 at 20:45

Here is another thread on this same subject that may help. It is basically the same thing but you need to install the linux-headers-generic too. [SOLVED] Lenova G480/Atheros AR8162 Woes

Also if you have wireless working you can try downloading the latest updates and restarting. That fixed my wired internet problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.