Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I booted up my computer yesterday and found I couldn't discover new bluetooth devices.. It works fine when booting into Windows, so I know my radio didn't die.

I'm using a VIZIO CT15-A5 laptop...

Here are some outputs for you:

funkdified@vizio ~ $ sudo bluetoothd -d -n
bluetoothd[2603]: Bluetooth daemon 4.101
bluetoothd[2603]: src/main.c:parse_config() parsing main.conf
bluetoothd[2603]: src/main.c:parse_config() discovto=0
bluetoothd[2603]: src/main.c:parse_config() pairto=0
bluetoothd[2603]: src/main.c:parse_config() pageto=8192
bluetoothd[2603]: src/main.c:parse_config() auto_to=60
bluetoothd[2603]: src/main.c:parse_config() name=%h-%d
bluetoothd[2603]: src/main.c:parse_config() class=0x000100
bluetoothd[2603]: src/main.c:parse_config() Key file does not have key 'DeviceID'
D-Bus setup failed: Name already in use
bluetoothd[2603]: Unable to get on D-Bus

Code:

blueman-browse
Loading configuration plugins
_________
SetAdapter (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:301)
None 
_________
on_property_changed (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:180)
adapter propery changed Discovering 1 
_________
on_property_changed (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:180)
adapter propery changed Discovering 0 
_________
on_property_changed (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:180)
adapter propery changed Discovering 1 
_________
destroy (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:128)
destroying 
_________
__del__ (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceSelectorWidget.py:81)
Deleting widget 
_________
__del__ (/usr/lib/python2.7/dist-packages/blueman/gui/DeviceList.py:63)
deleting mainlist

Code:

funkdified@vizio ~ $ rfkill list
0: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no
1: hci0: Bluetooth
   Soft blocked: no
   Hard blocked: no

Any help would be greatly appreciated. Not sure how it just died suddenly!

Kernel = 3.5.0-17-generic

Ubuntu = 12.10 64 bit version

share|improve this question
    
Can you press SHIFT on booting to display your GRUB and select your previous kernel - does this resolve your issue? –  fossfreedom Mar 22 '13 at 23:30
    
No I have tried this! –  Abram Mar 22 '13 at 23:31
    
Linux vizio 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux –  Abram Mar 22 '13 at 23:33
    
12.10 64 bit version –  Abram Mar 22 '13 at 23:34
    
Please edit your question with results and replies - we can then tidy up the comments. Why are you running such an old kernel? Please update to the latest kernel in the repos. –  fossfreedom Mar 22 '13 at 23:36
show 3 more comments

1 Answer 1

I would recommend first upgrading your 12.10 version. I have right here when running uname -a the version 3.5.0-26

So let's do an sudo apt-get update followed by a sudo apt-get upgrade and then reboot. When doing that, verify that any bluetooth related package (including python) gets updated. This update might be the solution. You would have to reboot to see if it works.

The output of bluetoothd suggest that it needs an update or a python library update. In both cases, the suggested update of the system might fix it. At least it worked for me but on a Desktop PC and a bluetooth dongle.

If not, maybe you can add the output of dmesg to include more information but am very positive that it will work after the update.

UPDATE: Ok now am certain that after upgrading you have a 99% chance of getting it to work. Right now you have the 4.101 version. most likely the first version for it. The current package version is the 4.101-0ubuntu6 which can be found in https://launchpad.net/ubuntu/+source/bluez/4.101-0ubuntu6/+changelog

I mentions the following changelog:

* debian/rules: add --enable-gatt (and remove the unrecognized configure
  options left over from previous releases). This fixes a regression in the
  support for Low Energy bluetooth devices such as thermometer probes and the
  like. (LP: #1055616)
share|improve this answer
    
Hi Luis, the main thing was updating the kernel, but thanks for your help. Bounty is yours as the other guy never bothered making an answer. –  Abram Mar 25 '13 at 6:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.