Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just bought a new computer, with specs:

motherboard Asrock E350M1
processor AMD Dual Core E-350
graphic card ATI Radeon HD6310

and tried to install ubuntu 12.10 on it, from a live usb.

I'm never able to get to the install screen, I keep getting error messages like:

udev[110]: timeout killing /sbin/modprobe -bv pci:[characters]
udev[110]: timeout killing /sbin/modprobe -bv pci:[characters]
udev[110]: timeout killing /sbin/modprobe -bv pci:[characters]
...

Reading this, it's possible that I would need to install AMD drivers but how am I supposed to do that if I can't even boot? Should I install them on the live usb before trying to boot? Or is it another problem?

Edit: I've seen someone solved this problem by selecting "Os Select: Other" instead of "Os select: Windows" in the BIOS, but the problem is I don't have a bios, I have the Asrock UEFI... And this option is not present in Asrock UEFI.

share|improve this question
    
I also tried with ubuntu 12.04 and same problem. Can someone point me in the good direction? –  Sullivan Orlean Mar 21 '13 at 12:48

1 Answer 1

up vote 2 down vote accepted

In Asrock uefi (F11 when booting), go to "Advanced", then "Storage configuration", and switch the option "SATA IDE Combined Mode" to Disabled.

Don't forget to install a 64 bit version of ubuntu also.

share|improve this answer
    
This worked for me. You should accept the answer! –  Paul A Jungwirth Oct 6 '13 at 5:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.