Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Google does not work, like just Google. This is the weirdest error I have ever seen.

Every 20-30 minutes Google stops working in my browser, any other page works. Then in 5-10 minutes, it just comes back.

Naturally the first thing I do is pull up the terminal and try to ping google.com. It works fine. Next, I try a different browser, still nothing. Next I try another computer on the same network, it loads Google no problem.

I tried both wired and wifi, I tried static ip and dynamic ip, nothing works. It seems to have a mind of its own. This is so hard to diagnose because of its intermittent nature.

Does anyone have any ideas?

share|improve this question
    
What do you mean by "Google stops working in my browser"? Is this a specific Google url or all Google urls? –  user25656 Mar 20 '13 at 12:37
1  
Anything on the google.com domain. –  giodamelio Mar 21 '13 at 0:52
2  
See if this helps: Problem resolving many of the Web Pages. I have a PPPoE connection and faced a somewhat similar problem considering only some of the websites didn't work at my end. –  Aditya Mar 24 '13 at 17:56
1  
what about localized domains such as google.fr or google.de? –  jasmines Mar 24 '13 at 20:24
    
Have you tried to reboot the computer (thinking of cache issue)? Do you have the latest updates of your Ubuntu distro? What version of Ubuntu do you have (could be a bug in the networking software)? What network card do you have? –  Alvar Mar 26 '13 at 16:07
show 1 more comment

3 Answers

Some (trivial, basic) ideas

  • reset your router (or at least inspect its settings)
  • clear browsers' cookies & cache
  • reboot (inter alia this will clear tmp, can't harm)
  • try in different browsers
  • try with a proxy (should almost definitely work)
share|improve this answer
add comment
up vote 4 down vote accepted

After trying a ton of things, I got frustrated and just reinstalled Ubuntu. Since then, the problem seems to have gone away.

share|improve this answer
    
I always have a usb with install on and a hard drive for making backups for just these sorts of occasions. Glad it's fixed for you now anyway. –  Magpie Mar 30 '13 at 17:20
    
I tried reinstalling too. However same problem came back some time later :S This is my question: askubuntu.com/questions/315955/… –  Can Jul 3 '13 at 20:10
add comment

Probably a failed but cached DNS query.

$ sudo /etc/init.d/dnsmasq restart  

or

# service dnsmasq restart

Then restart whatever browser you are using to wipe it's cache.

Maybe some app or plug-in you had, but forgot about, was wiped out on the re-install.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.