Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a locked microSD (locked by Nokia symbian phone), I forgot the password, how do I unlock it? I don't mind if I lost my data in microSD. I can't mount it.

enter image description here

Output of mkdir ~/sd_mount && sudo mount /dev/sdb ~/sd_mount and sudo fdisk -l:

enter image description here

share|improve this question
    
What happens if you try to mount it manually (mkdir ~/sd_mount && sudo mount /dev/sdb ~/sd_mount)? Also if you can update your answer with the output of sudo fdisk -l. –  Salem Mar 22 '13 at 15:14
    
I'll try it in couple days, probably Monday, I lend the SD card to my friend, he is a computer geek, I hope he can help me. I'll post the result here if the problem solved. –  Nur Mar 22 '13 at 17:49
    
@Salem I have updated my question. –  Nur Mar 25 '13 at 5:18
    
It may be silly, but have you tried this? –  Salem Apr 12 '13 at 17:37
    
@Salem It'a microSD, no physical lock like on SD card. I formated it and lost all of the data, but the card still locked. –  Nur Apr 14 '13 at 9:40
add comment

1 Answer

Does gparted list the device? If so and recovering the data is unimportant to you, or you fail doing so, you can format the drive to a suitable standard. For Unixoid systems as e.g. android this could be ext2/3 or a a universal standard NTFS or FAT 32. In the last case you should select yout format depending on the data you plan to save on the sd-card: In case you don't intend to save files bigger than 4GB or the sd-card by itslef is limited to a memory of under 4GB you can select the simple FAT32, otherwise you should select NTFS. Ubuntu can handle both formats while windows will not recognize ext-filesystems.

share|improve this answer
    
GParted doesnt detect the memory card, in device list only /dev/sda shown. Only Disks detect it as sdb, like shown in my question. –  Nur Mar 22 '13 at 17:46
    
Gparted only list sda –  Nur Mar 25 '13 at 5:19
    
I have tried to format it using another Nokia phone, but it's still locked. –  Nur Mar 27 '13 at 10:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.