Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I downloaded and mounted the iso to install the 64 bit wubi, but every time I run it it gets stuck on "Downloading ubuntu-12.04.2-wubi-amd64.tar.xz . I've seen other people with this problem who never seem to get it solved.

I'm running on a 64-bit Windows 7 Home Premium machine, my internet connection is fine, I'm just not sure what the problem is or how to fix it.

Any advice is very appreciated.

share|improve this question
How long have you been waiting? It usually takes a long time. – Linuxios Mar 20 '13 at 3:08
There is a bug in Wubi 12.04.2 that cannot use the ISO (you shouldn't mount it either but that won't help because of the bug). Therefore there is no point in downloading it. Wubi.exe must instead download the diskimage (500MB) so that will take some time. You can manually download it, but the it requires a --dimagepath= argument to find it as explained here – bcbc Mar 20 '13 at 3:17

There is a bug on 12.04.02 64bit. Try using 12.04.01 instead and do an upgrade to get to 12.10. Also, do not mount the ISO. There is no need, it will just cause problems...

share|improve this answer

Please wait for sometime, it may take some time i waited on ubuntu 12.04.1 it is done you can get it on this is 32 bit and is 64 bit as per your requirements. Don't be confused, first link is ubuntu 12.04.1 lts 32 bit and second one is ubuntu 12.04.1 lts is 64 bit. lts stands for long term support

share|improve this answer

It's not stuck, it downloads slow even in fast networks because Wubi can't download amd64.tar.xz very fast, actually, mine is even slow, but if you have an extreme network like 4mbps or higher, I think because I have 3mbps, I waited and when the 15 minutes is actually 10 minutes but I felt like it was 20 minutes waiting time. So if you don't understand how this works, use the CD Installation of Ubuntu to have no waiting time for this.

If it still doesn't download wubi-amd64.tar.xz, this might be a bug on the 12.04.02, and maybe try using the 12.04.01 version of download (using the CD, maybe), and never mount the ISO, or it might cause problems.

If this doesn't work, try other answers.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.