Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First, I installed Windows 8 in my desktop PC. (Not pre-installed... I did it by myself). Then I booted the Ubuntu dvd in UEFI mode (Did the same with Windows 8) and installed Ubuntu 12.10 64bit. Everything went perfectly. After rebooting, there's no grub! The system took me directly to Ubuntu! I can't log into Windows 8. Please help! Earlier, I used Boot Repair and it messd up with my Windows EFI files. So I was unable to boot Windows even after removing Ubuntu. I can't use boot repair. Now this is a new fresh install, Please tell me how to boot into both Windows 8 and Ubuntu!

Here is my /etc/defaults/grub :

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=1024×768
#GRUB_GFXPAYLOAD_LINUX=1024×768

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
share|improve this question
1  
Hi there, to have grub menu when booting, please follow this tutorial askubuntu.com/questions/152553/… –  penreturns Mar 20 '13 at 2:54
    
@penreturn Thanks! It brought back grub. But can't boot to Windows 8. I added it by following this guide askubuntu.com/questions/210914/… . Now grub gives an error when selecting windows 8 : error: file '/EFI/microsoft/BOOT/bootmgfw.efi' not found. But when checking, through Ubuntu, i can find that file –  EApubs Mar 20 '13 at 3:06
1  
I suggest you refer this. askubuntu.com/questions/216215/invalid-efi-file-path . Scroll to bottom on the comment section. –  penreturns Mar 20 '13 at 3:09
    
@penreturn Thanks a lot! It helped! Shall I delete this question because the answer is already there. Or shall I add an answer combining all the answers into one. –  EApubs Mar 20 '13 at 3:12
    
I believe mods will take care about it. Enjoy Ubuntu! –  penreturns Mar 20 '13 at 3:14
add comment

2 Answers 2

I recently installed Windows 8 Pro to an extra hard drive on my PC. My system which runs Ubuntu primarily and boots up through GRUB couldn't seem to find the new OS after I installed it. So I searched and read all of these solutions involving manually re-configuring GRUB system files, uninstalling and re-installing Windows, etc. All of these are terrible solutions. The best solution is so, so easy. All you have to do is run this update command for GRUB from a terminal window within your Linux distro:

$ sudo update-grub

It searches your hard drives for new kernels and OSs. Problem Solved. Enjoy!

share|improve this answer
add comment

Run Boot-Repair --> Advanced Options --> tick Restore EFI backups --> Apply , and indicate the new URL that will appear. Reboot, you should get back access to Windows.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.