Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I read Seth's post here: How do I install LibreOffice 4?. I wanted to upgrade, so I ran the commands as provided by Mik to upgrade using stable ppa.
For some reason now when I try to run LibreOffice it starts up, shows the splash screen, loads about maybe 2-3% and then quits, giving me an Ubuntu error. I might have only partially updated/upgraded, so this might be part of the problem...I'm not sure.

HELP!! I really need to use LibreOffice for a Biology class I have. I can use Abiword for now, but I really prefer LibreOffice.
I want to try and fix it, but if I don't get a quick answer I am afraid I may have to go to (Heaven forbid) Windows XP I dual-boot with to use MS Word/Open Office.

Here's the error output I got when I launched writer from terminal:
nate@texno-Satellite-A105:~$ libreoffice --writer
javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx
terminate called after throwing an instance of com::sun::star::uno::DeploymentException'

share|improve this question
1  
What is the actual error? Please put it in your question. –  nerof61 Mar 19 '13 at 15:27
    
It's not doing it now, it just quits, no error :( It was giving me the error prior to the reboot I did. –  RPi_Awesomeness Mar 19 '13 at 15:28
    
Boot it from terminal? –  nerof61 Mar 19 '13 at 15:30
    
Ok, I will try starting it from terminal. Done! –  RPi_Awesomeness Mar 19 '13 at 15:32
    

1 Answer 1

up vote 2 down vote accepted

In this case the solution centered around my suggestion that files in ~/.config/libreoffice were causing the problems after the upgrade.

Important Note: you may want to make a copy of your libreoffice folder if it has any important custom files in it before you remove it.

If the permissions are correct and libreoffice still doesn't launch, then delete ~/.config/libreoffice in your filebrowser or with

rm -rf ~/.config/libreoffice

and libreoffice will regenerate a new folder when it starts.


If, for future readers, the suggestions made so far are unsuccessful, you could install ppa-purge with

sudo apt-get install ppa-purge

and downgrade all the libreoffice packages by entering

sudo ppa-purge ppa:libreoffice/libreoffice-4-0

and then reinstall the standard repository version of libreoffice.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.