Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

System: Ubuntu 12.10, nVidia Geforce GT240 (nvidia-current privative driver), LG display connected to VGA-0

The 1920x1080 resolution is not listed, I've added it in Windows but I'm having problems doing the same Ubuntu.

Step 1) Obtain modeline

$ cvt 1920 1080

Step 2) Create custom mode

$ xrandr --newmode "1080p"  172.80  1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync

Step 3) Add custom mode

$ xrandr --addmode VGA-0 "1080p"

And then I get this error:

X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  29
  Current serial number in output stream:  30

The xrandr output is

Screen 0: minimum 8 x 8, current 1152 x 864, maximum 8192 x 8192
VGA-0 connected 1152x864+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0 +
   1360x768       60.0     59.8  
   1152x864       60.0* 
   800x600        72.2     60.3     56.2  
   680x384       119.9    119.6  
   640x480        59.9  
   512x384       120.0  
   400x300       144.4  
   320x240       120.1  
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
  1080p (0x2f7)  172.8MHz
        h: width  1920 start 2040 end 2248 total 2576 skew    0 clock   67.1KHz
        v: height 1080 start 1081 end 1084 total 1118           clock   60.0Hz

Am I doing something wrong?

share|improve this question
    
It seems I'm not the only one with this problem. Same Ubuntu version, same graphic card. –  Bruno A. Mar 19 '13 at 11:48

1 Answer 1

up vote 1 down vote accepted

Ok, this worked for me.

1) Edit /etc/X11/xorg.conf

2) In the section "Monitor", change HorizSync and VertRefresh to the correct values (consult your monitor specifications in the user manual). This is important or you will likely get an "signal out of range/sync" error in your monitor (if you make this mistake press ctr+alt+f1 and edit xorg.conf from console).

Section "Monitor"

    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-0"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

3) In the section "Screen" add this line.

Option "ModeValidation" "AllowNonEdidModes, NoVirtualSizeCheck, NoMaxPClkCheck, NoWidthAlignmentCheck, NoExtendedGpuCapabilitiesCheck"

4) Restart the system.

5) xrandr --addmode still won't work but you will have more resolutions available. Check out my new xrandr output:

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 8192 x 8192
VGA-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       75.0 +   70.1     60.0  
   1920x1200      60.0  
   1920x1080      60.0*    59.9  
   1792x1344      60.0  
   1680x1050      74.9     69.9     60.0     59.9  
   1600x1200      65.0     60.0  
   1440x900       59.9  
   1400x1050      74.8     70.0     60.0  
   1360x768       60.0     59.8  
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1152x864       75.0     75.0     70.0     60.0  
   960x600       120.0  
   960x540       120.0  
   840x525       149.9    139.8    120.0    119.8  
   832x624        74.6  
   800x600        75.0     72.2     60.3     56.2  
   720x450       119.8  
   700x525       149.5    120.0  
   680x384       119.9    119.6  
   640x480        75.0     72.8     59.9  
   512x384       140.1    120.0  
   400x300       144.4  
   320x240       145.6    120.1  
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.