Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I got an error icon above my menu bar. When I click on it I get three options with some details. It says

An error occurred please run package manager from the right-click menu or apt-get in terminal to see what's wrong.
The error message was: 'Error:brokencount>0'.
This usually means that your installed packages have unmet dependencies"

I tried apt-get in terminal, with commands and options it says

See the apt-get(8), sources.list(5) and apt.conf(5) manual pages for more information and options. This APT has Super Cow Powers.

When I tried to update my system it failed to update and showed this error message:

The package is broken

The following packages have unmet dependencies:
steam-launcher: Depends: curl but it is not installed
                Depends: jockey-common but it is not installed
                Depends: libc6 (>= 2.15) but 2.15-0ubuntu20 is installed
share|improve this question

marked as duplicate by Eliah Kagan, con-f-use, Raja, hhlp, Kevin Bowen Mar 20 '13 at 10:35

This question was marked as an exact duplicate of an existing question.

Try in a terminal:

sudo apt-get update
sudo apt-get autoclean
sudo apt-get autoremove
sudo apt-get -f dist-upgrade

It should update package list, remove any unnecessary packages, fix broken packages and manage dependencies.

share|improve this answer
if you try and have an error, can you let me know ? – ttoine Mar 19 '13 at 14:53
I tried these commands sir but when I try last command it shows me this – Faisal Aslam Mar 20 '13 at 13:21
Failed to fetch… 403 Forbidden [IP: 80] E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing? – Faisal Aslam Mar 20 '13 at 13:23
it seems you have many problems with packages. you should try changing the mirror you are using to main, and update again. – ttoine Mar 21 '13 at 12:13

sudo apt-get install steam-launcher This command should install steam-launcher and the dependencies that needs. If you continues with problem maybe you can try using sudo apt-get install -f steam-launcher

share|improve this answer
by trying this command sudo apt-get install steam-launcher I got this error Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package steam-launcher – Faisal Aslam Mar 20 '13 at 13:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.