Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i got a used hp mini yesterdayand installed ubuntu 12.10 today. like others, i cannot connect to a wireless network. "enable networking" is checked but no connection options appear. ethernet works. network settings only gives the options "wired" and "network proxy".

i tried the command "sudo lshs -c network" but get "command not found".

in addition, suddenly my arrow keys aren't working (pretty sure they were working yday though). so when i reboot, i can't choose ubuntu since i can't go down... (not sure if i should open a different thread for this). sorry, i rechecked. it's only the "up" and "down" arrows that don't work. it's hardware problem then?

thanks!

share|improve this question
    
What model HP Mini? eg. 210-1000, 210-3000, etc. Also, try sudo lshw -c network instead. –  david6 Mar 19 '13 at 10:42
    
its an HP mini 210-1000. i had to restart the laptop, and since the "up" and "down" arrow keys don't work, i'm unable to boot ubuntu now. is there any other key/shortcut to get me into ubuntu (or maybe to get rid of windows all together so i am not asked to choose) so i can run the command david6 suggested? –  user141602 Mar 19 '13 at 14:14
    
Welcome to Ask Ubuntu! Please provide additional information only by editing your question and not within a comment. Comments might/will eventually be deleted and so your information would get lost. You can always edit your own question. –  guntbert Mar 19 '13 at 15:35
add comment

2 Answers 2

I have this wireless problem too in HP mini 110 1013tu, install additional driver for broadcom wireless device fix the problem.

share|improve this answer
    
its an HP mini 210-1000. i had to restart the laptop, and since the " down" arrow key doesn't work, i'm unable to boot ubuntu. is there any other key that will get me there so i can run the command david6 suggested? thanks, nur, did u install it from the software center? –  user141602 Mar 19 '13 at 11:50
    
I don't have any problem with my keyboard, sorry I can't help for that :(. Since you just installed Ubuntu today I recommend to reinstall your system. And for additional driver, just search for Software Sources on your Dash, click additional driver tab. –  Nur Mar 19 '13 at 11:57
    
yeah, i really can't get back into ubuntu and it's no good to reinstall ubuntu every time. is there any way to choose "ubuntu" when booting? if not, can i somehow get rid of windows so i don't have to choose? –  user141602 Mar 19 '13 at 12:12
    
Have you try Boot Repair (help.ubuntu.com/community/Boot-Repair)? It can solve bootloader problem automatically, just follow the step provided, and after fixing the boot menu, your Ubuntu will be in first choice of the list (no need for 'down arrow' anymore, in case your 'down arrow' problem not solved). You can install it on Ubuntu LiveCD, you don't have to reinstall your current Ubuntu or Windows partition. –  Nur Mar 19 '13 at 16:06
add comment

I have run Ubuntu 12.04 LTS on an HP Mini 210-1000, with no issues.


However, there are issues with Ubuntu 12.10 (and similar for 210-2000 and 210-3000) - due to newer kernels and different chipsets for WiFi.

For better results (regardless of Ubuntu version), you should also upgrade to 2GB RAM.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.