Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have to wait a long time (about 15s) after entering login credentials. I read some other posts but didn't find anything relevant to my situation. In the .xsession-errors log, there are two errors and I think one of them could be the cause of the delayed login.

compiz (core) - Info: Starting plugin: session
I/O warning : failed to load external entity "/home/user/.compiz/session/10e5e71fff61fc4529136368274098992100000031290040"

and the below nautilus error even though I have disabled Personal File Sharing in startup applications.

Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255:  
net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory

If one of these is the reason, please help me resolve it. Or let me know what else I could try out.

Update: I removed nautilus-share and dont get that 2nd error anymore.
Any idea what that compiz error means?

share|improve this question
add comment

1 Answer

To solve nautilus error try with: I sort this problem creating a group call admin:

sudo groupadd admin

Check that the admin group is part of the sudoers:

sudo cat /etc/sudoers

Now you add your user to the admin group :

sudo usermod -aG admin username

you can check if your user is part of the group :

sudo cat /etc/group | grep '^admin'

Source: How to enable user sharing per instructions?

sMl

share|improve this answer
    
Actually I dont need this file share option. Is there a way to completely disable this? –  nariknahom Mar 19 '13 at 11:34
    
sudo aptitude remove --purge system-config-samba samba-common-bin samba-common samba –  smile Mar 19 '13 at 11:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.