Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just had some surprising results when running hard drive performance tests in Ubuntu 12.10 vs Linux Mint Debian Edition, which I'm dual-booting on the same machine (and the same hard drive).

I was running some tests for a Ruby application I'm working on, and the test suite came out at 19 minutes 19 seconds on Ubuntu 12.10. The test suite runs much more quickly on a range of other machines, so I decided to reboot into LMDE and run it again. It came out at 9 minutes 19 seconds on LMDE.

This was quite surprising - the Ubuntu installation runs tests only half as fast on the exact same machine - so I ran hdparm in order to see what the disk read speeds were (the limiting factor in these tests is likely to be how fast the tests can class-load themselves, and load fixture data from disk).

hdparm says the following:

*Ubuntu 12.10*

/dev/sda:
 Timing cached reads:   1900 MB in  2.00 seconds = 950.19 MB/sec
 Timing buffered disk reads: 248 MB in  3.01 seconds =  82.29 MB/sec


*LMDE*

/dev/sda:
 Timing cached reads:   7588 MB in  2.00 seconds = 3796.70 MB/sec
 Timing buffered disk reads: 216 MB in  3.01 seconds =  71.73 MB/sec

The difference in test execution speed is explained here. LMDE is reading cached info nearly 4 times as quickly off the disk.

Are there hdparm settings that I can use to speed up the Ubuntu installation ?

Are there any known issues affecting hard drive performance that I can work around in some way ?

share|improve this question
    
Could you post the output of: # cat /sys/block/sda/queue/scheduler –  kingmilo Mar 19 '13 at 9:05
    
@kingmilo # cat /sys/block/sda/queue/scheduler gives noop [deadline] cfq –  futurechimp Mar 19 '13 at 20:27
    
That looks fine. There was a bug reported in one of the latest kernel versions that showed reduced disk performance when the scheduler was not set to noop. –  kingmilo Mar 20 '13 at 6:59
    
Cool. I did some reading on I/O schedulers as a result of your comment. Good times :). –  futurechimp Mar 20 '13 at 11:05
    
Awesome. Perhaps it is a case of increase the cache for the disk or modifying the cache options. Are you using ext4 filesystem? –  kingmilo Mar 20 '13 at 12:54
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.